Appliquer une formule RECHERCHEV à toute une colonne

Résolu/Fermé
ValZCK Messages postés 22 Date d'inscription mercredi 22 avril 2015 Statut Membre Dernière intervention 9 juillet 2015 - 22 avril 2015 à 10:55
ValZCK Messages postés 22 Date d'inscription mercredi 22 avril 2015 Statut Membre Dernière intervention 9 juillet 2015 - 22 avril 2015 à 11:37
Bonjour,

Voilà une petite heure que je cherche comment copier ma formule située en haut de colonne au reste de cette dernière, MAIS lorsque j'utilise les moyens habituels les données à l'intérieur de ma formule s'incrémentent de +1 ce qui en soit est normal !

Ce que je souhaiterais; c'est que cette formule : =RECHERCHEV(D3;DptRégion!B3:D98;2;VRAI) soit appliquée à toute ma colonne, avec seulement la première valeur "D3" qui s'incrémente, pour devenir "D4", "D5", etccc
Le problème c'est que ma table de donnée "B3:D98" s'incrémente elle aussi et devient "B4:D99", puis "B5:D100", etccc

Etant donné qu'il y a une centaine de cellules, je n'ai pas la patience de les modifiées une part une, de plus j'en rajouterai au fil du temps.

Merci d'avance pour vos réponses

ValZCK

1 réponse

Mike-31 Messages postés 18048 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 19 septembre 2022 4 993
22 avril 2015 à 11:03
Bonjour,

Regarde comme cela

=RECHERCHEV(D3;DptRégion!$B$3:$D$98;2;VRAI)
mais si tu nommais la plage DptRégion!B3:D98 exemple Tab
la formule deviendrait
=RECHERCHEV(D3;Tab;2;VRAI)
3
ValZCK Messages postés 22 Date d'inscription mercredi 22 avril 2015 Statut Membre Dernière intervention 9 juillet 2015
Modifié par ValZCK le 22/04/2015 à 11:44
Merci beaucoup :)
Il est vrai que nommer une plage est toujours une bonne chose

A+
0