Compter les cellules d'une même couleur (avc mise en formecondi) [Résolu/Fermé]

Signaler
-
 Math -
Bonjour,

Je recherche depuis quelques jours un Macro qui pourrait compter toutes les cellules d'une même couleurs.

Cependant les couleurs sont utilisées comme élément de comparaison grâce à des mises en formes conditionnelles. 3 couleurs différentes : verte cellule B1 supérieur à A1, Jaune cellule B1 égale à A1 et Rouge cellule B1 inférieur à A1.

J'ai trouvé un macro qui comptabilise une seule couleur a partir d'un code couleur. Lorsque je recherche l'index de la couleur c'est toujours le vert qui sort avec le code -4142 même si la cellule est jaune ou rouge. Le vert est la première des trois mises en forme conditionnelles.

Avez vous des réponses à mon problème ?

Merci d'avance !



2 réponses

Messages postés
15528
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
25 janvier 2021
1 440
Bonjour,

au plus simple, dans la macro faire les memes tests que pour vos MFC
Messages postés
16376
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 janvier 2021
3 118
Bonjour
Peut-^tre nous dire ou se trouvent les cellules à tester...
Bonjour,

En effet, alors voici une exemple du positionnement:
A1 cellule à saisir, B1 C1 D1 cellules références qui changeront de couleurs en fonction de la valeur de A1. Ainsi de suite jusqu'à A10.
Mon objectif : comptabiliser en B11 les cellules vertes de la colonne B, en B12 les cellules jaunes et en B13 les rouges.

J'imagine qu'il faudra faire une mise a jour régulière de la macro dès que les couleurs changeront.

Merci pour vos réponses.

Ps: f894009 je ne sais pas modifier un code VB. J'ai trouvé l'actuel sur le forum.
Messages postés
16376
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 janvier 2021
3 118
re,
Sans macro
en B11=SOMME(SI(B1:B10>A1:A10;1)) 'vert
en B12=SOMME(SI(B1:B10=A1:A10;1)) 'jaune
en B13=SOMME(SI(B1:B10<A1:A10;1)) 'rouge
Formules matricielles à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule
on peut aussi le faire par un sommeprod
pour le vert
=SOMMEPROD((B1:B10=A1:A10)*1)
etc pour jaune et rouge

La maquette-démo par matricielle
https://www.cjoint.com/?3Dqoy71643n
Merci pour votre réponse et votre formule. Il me semble que dans mon cas elle ne fonctionne pas.

J'ai oublier un détail qui a, je pense, son importance...
La plage de donnée n'est pas solidaire.
CAD: que la mise en forme conditionnel réagit par ligne. B1, C1. et D1 se compare uniquement à A1.
Pour B2, C2, et D2 c'est avec A2.

Voulez vous mon fichier pour avoir un une vision claire de la situation?
Si oui voici mon email: ***@*** envoyez moi un mail je vous répondrais avec le fichier.

Merci bcp
Messages postés
16376
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 janvier 2021
3 118 > Math
As tu essayé et regarder la maquette ?
rappel:
il s'agit de formules matricielles ou aussi^par sommeprod
En réalité vos explications dépasses mes compétences ^^
J'ai trouvé un compromis en ajoutant une colonne (cachée) où je complète la MFC par une formule Si pour obtenir une valeur. Je fais ensuite le total avec une Somme.Si et j'arrive à obtenir mon résultats!
Merci pour m'avoir accordé du temps!