Problème sommeprod excel 2010

Résolu/Fermé
Signaler
Messages postés
9
Date d'inscription
vendredi 10 avril 2015
Statut
Membre
Dernière intervention
25 septembre 2015
-
Messages postés
454
Date d'inscription
mercredi 8 février 2012
Statut
Membre
Dernière intervention
13 août 2015
-
Bonjour à toutes et tous,

Je suis littéralement en train de m'arracher les cheveux!

Dans le cadre professionnel, nous avons des fichiers temps par salarié dans lesquels ils renseignent les heures qu'ils font par jour et par projet.

Pour un projet particulier je dois calculer le nombre d'heures (converties en jour) travaillées par jour et par mois et isoler les codes correspondant à ce projet dans la formule. En utilisant la formule sommeprod, j'obtiens les bons résultats pour Janvier et Février et allez savoir pourquoi cela ne marche pas pour Mars et Avril!!!

J'ai essayé plusieurs choses mais rien ne fonctionne c'est pour cela que je viens demander votre aide.

Voici le lien du fichier: http://we.tl/TVg7LqqIyy

En vous remerciant par avance,

2 réponses

Messages postés
26318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 décembre 2021
6 135
Bonjour
il y apparemment un problème de formatage des cellules entre la colonne D et la colonne I
certaines sont été entrées en texte, d'autres en standard et quand vous reformatez, le texte ne devient pas num

faites cette manip pour retrouver vos affichages
1° formatez les colonnes D et I en standard
2° copier une cellule vide hors champ
3° sélectionnez la colonne D complète
4° clic droit / collage spécial et cochez "addition"
même opération sur la colonne I

Çà devrait s'arranger et donner ça
https://www.cjoint.com/c/EDklTLCLt9Q
crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
9
Date d'inscription
vendredi 10 avril 2015
Statut
Membre
Dernière intervention
25 septembre 2015

Je vous remercie de votre réponse rapide, ça a bien marché pour Mars mais pour Avril je n'ai toujours que des 0 et pourtant j'ai fait glisser la formule de la colonne de Mars...
Messages postés
9
Date d'inscription
vendredi 10 avril 2015
Statut
Membre
Dernière intervention
25 septembre 2015

Autant pour moi j'ai réussi à régler le problème, je vous remercie
Messages postés
26318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 décembre 2021
6 135
Le problème n'est pas dans les formules, mais dans le format des colonnes D et I, avez vous bien "numérisé" toutes les valeurs?
C à d colonne c D et I complètes)
Voyez le fichier que je vous renvoie qui apparemment fonctionne?
crdlmnt
Messages postés
454
Date d'inscription
mercredi 8 février 2012
Statut
Membre
Dernière intervention
13 août 2015
499
Une solution pour toi :


http://www.cjoint.com/confirm.php?cjoint=3DkmedytDgh

Dis moi si ça te convient ? Dans le fichier j'ai oublié de divisé par 7. A rajouter à la fin de la formule dans le tableau jaune