Mise à jour skrooge

Résolu/Fermé
jeclaude33 Messages postés 185 Date d'inscription mercredi 14 mars 2007 Statut Membre Dernière intervention 18 juin 2022 - 31 mars 2015 à 09:41
mamiemando Messages postés 33158 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 21 juin 2024 - 7 avril 2015 à 21:30
Bonjour,
Jusqu'a maintenant j'étais sous ubuntu mais devant tous ces plantages j'ai décidé de passé sous KDE.
Malheureusement, la version de skrooge sous ubuntu était plus récente que celle ci et il m'ai impossible d'importer mes comptes.
KDE: 4.8.4
Skrooge:1.3.0
pourriez vous m'aider, sachant que je suis un débutant en informatique et que sous debian j'ai des difficultés!
Voici les manips que j'ai fait:
su add-apt-repository ppa:s-mankowski/ppa
su apt-get update
su apt-get install skrooge
mais ça m'écrit que j'ai la dernière version.
Pouvez vous m'aider?
merci
A voir également:

3 réponses

mamiemando Messages postés 33158 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 21 juin 2024 7 760
Modifié par mamiemando le 3/04/2015 à 10:30
Merci de soigner l'orthographe.

Jusqu'a maintenant j'étais sous ubuntu mais devant tous ces plantages j'ai décidé de passé sous KDE.

Attention il ne faut pas mélanger la distribution (ubuntu, debian, fedora, ...) et l'environnement graphique que tu utilises (kde, gnome, unity). Un environnement graphique est une suite logicielle et rien n'empêche d'installer à la fois unity et kde par exemple.

Par ailleurs il ne fait pas croire que kubuntu/ubuntu/xubuntu/... sont des distributions différentes (ça, c'est qu'on veut te faire croire) : c'est une seule et même distribution (ubuntu) mais qui se préinstalle avec un jeu de paquets différents (par exemple les paquets kde dans le cas de kubuntu, xfce dans le cas de xubuntu, etc).

Malheureusement, la version de skrooge sous ubuntu était plus récente que celle ci et il m'est impossible d'importer mes comptes.

Quelle version utilisais-tu sous ubuntu ? La version la plus récente disponible sous debian est :
https://packages.debian.org/fr/sid/skrooge

Au pire tu peux la récupérer sur cette page et l'installer avec la commande
dpkg -i


Ceci va par exemple t'amener à télécharger si tu veux le paquet unstable actuel amd64 :
http://ftp.fr.debian.org/debian/pool/main/s/skrooge/skrooge_1.9.3-1_amd64.deb

Du coup tu pourrais lancer :

su -
wget http://ftp.fr.debian.org/debian/pool/main/s/skrooge/skrooge_1.9.3-1_amd64.deb
dpkg -i skrooge_1.9.3-1_amd64.deb

Voici les manips que j'ai fait:
su add-apt-repository ppa:s-mankowski/ppa


Oula c'est pas top. Déjà ce serait plutôt
sudo
au lieu de
su
, ou à la rigueur
su -c
. Ajouter des dépôts ppa n'est généralement pas nécessaire sous debian. Dans le cas présent tu as par exemple installé une debian stable, et il suffirait de prendre le paquet en version testing ou unstable.

Une manière de faire consiste à récupérer le paquet à la main via le site de packages de debian (cf lien précédent), en espérant que ses dépendances soient satisfaites. Si ce n'est pas le cas, une solution consiste à utiliser /etc/apt/preferences pour jongler entre deux versions de debian. Voir :
https://www.mistra.fr/tutoriel-linux-apt-configuration.html

Bonne chance
0
jeclaude33 Messages postés 185 Date d'inscription mercredi 14 mars 2007 Statut Membre Dernière intervention 18 juin 2022 14
3 avril 2015 à 17:21
Bonjour,
merci pour la réponse. J'ai cherché sans réussir les solutions que tu me proposes (je ne suis pas doué) et je suis allé sur mistra en suivant ton lien; la j'ai suivi pas à pas les infos proposées et la mise à jour de skrooge s'est faite (version 1.9....)
Quand j'ai redémarré l'ordi, j'arrive comme d'habitude sur l'identification et j'ai un message qui me demande de choisir la version à ouvrir, et je m'aperçois que je n'ai plus que la version par défaut ou de secours. Hélas, après avoir rentré les identifiants j'arrive sur la page d'accueil de debian mais aucune icone, rien!
La, je t'envoie mon commentaire depuis windows et je sais que ça va être dur de réparer ça. Je peux réinstaller si nécessaire, mais j'aimerais avoir la dernière version de debian à graver sur cd étant donné qu'il y a plusieurs choix et difficile lorsque l'on ne connaît pas de faire le bon choix.
Merci
cordialement.
0
mamiemando Messages postés 33158 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 21 juin 2024 7 760
5 avril 2015 à 00:32
Qu'appelles-tu la "version par défaut" ou "de secours" ? Est-ce que le mode graphique se lance ? Peux-tu prendre une capture d'écran ou une photo de ton écran quand tu démarres, car là je n'ai pas très bien compris où tu en es rendu ?

Bon sinon pas d'affolement, tant que le mode texte se lance, c'est réparable :-)

Peux-t'identifier en mode texte et me reporter le contenu de /etc/apt/sources.list ?

Pour le savoir, une fois identifié en mode texte...
https://www.mistra.fr/tutoriel-linux-mode-texte.html

... lance :

cat /etc/apt/sources.list


... et reporte-nous le résultat.

Si tu n'es pas à l'aise sous debian et que tu n'as pas grand chose d'installé, le plus simple serait peut-être pour toi de réinstaller debian directement dans une version assez récente (genre jessie) qui est en 1.9.3-1. Pense alors au préalable à sauver tes documents précieux (si tu en as) sur un support tiers...
https://www.debian.org/devel/debian-installer/

Bonne chance
0
jeclaude33 Messages postés 185 Date d'inscription mercredi 14 mars 2007 Statut Membre Dernière intervention 18 juin 2022 14
Modifié par jeclaude33 le 6/04/2015 à 13:25
Me revoila
Bonne fêtes de Paques.
J'ai réinstallé le système mais j'en suis toujours au même point: j'ai beau installé et désinstaller skrooge, j'ai toujours la version 1.3.0.
que faire?
après avoir téléchargé la version récente de skrooge , je fait comment pour l'installer?
voici le détail de la console:root@debian:/home/jcl# apt-get install skrooge 1.9.3
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Note : sélection de libghc-case-insensitive-dev-0.4.0.1-99380 pour l'expression rationnelle « 1.9.3 »
Note : sélection de libghc-case-insensitive-prof-0.4.0.1-99380 pour l'expression rationnelle « 1.9.3 »
Note : sélection de ruby1.9.3 pour l'expression rationnelle « 1.9.3 »
Note : sélection de « libghc-case-insensitive-dev » au lieu de « libghc-case-insensitive-dev-0.4.0.1-99380 »
Note : sélection de « libghc-case-insensitive-prof » au lieu de « libghc-case-insensitive-prof-0.4.0.1-99380 »
libghc-case-insensitive-dev est déjà la plus récente version disponible.
libghc-case-insensitive-prof est déjà la plus récente version disponible.
skrooge est déjà la plus récente version disponible.
ruby1.9.3 est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

merci pour ton aide. Si tu peux m'aider merci de m'expliquer pas à pas.
0
mamiemando Messages postés 33158 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 21 juin 2024 7 760
6 avril 2015 à 13:34
Joyeuses Pâques également :-)

Tu ne peux pas dans apt-get le numéro de version du paquet comme tu viens de le faire. En gros, apt examine quelle est la dernière version référencée de chaque paquet fourni par chaque dépôt et prend la plus récente.

Si les versions de skrooge qui te sont proposées sont trop vieilles il faut soit installer cette version manuellement, soit ajouter des dépôts (par exemple testing ou unstable si tu es en stable) pour disposer de versions plus récentes.

Trois stratégies sont possible

1) Basculer complètement vers une release plus récente que celle que tu utilises (en migrant par exemple de stable à testing, alias de wheezy à jessie)

2) Tu peux panacher des paquets stable et testing (via /etc/apt/preferences).

3) Tu peux aussi télécharger une version testing ou unstable de ce paquet en espérant que les dépendances stables suffisent (si c'est trop fastidieux il vaut mieux utiliser /etc/apt/preferences).

Personnellement je te conseille d'installer ou de migrer vers une jessie (après avoir sauvé tes documents importants sur un support tiers au préalable) puisque skrooge est en version 1.9.3 qui semble correspondre à tes besoins...

Si tu veux plus de détails, indique moi quelle stratégie tu veux adopter.

Bonne chance
0
jeclaude33 Messages postés 185 Date d'inscription mercredi 14 mars 2007 Statut Membre Dernière intervention 18 juin 2022 14
6 avril 2015 à 13:47
Pour l'instant je n'ai rien à sauvegarder vu que j'étais sous windows et que tout est sauvegarder sur une partition. Je veux bien suivre tes conseils, (migrer vers jessie) en suivant tes indications.
merci
0
mamiemando Messages postés 33158 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 21 juin 2024 7 760
Modifié par mamiemando le 7/04/2015 à 09:10
Si tu n'as rien à sauver installe simplement jessie (= debian testing actuellement) par ton ancienne installation.
https://www.debian.org/CD/http-ftp/index.fr.html

Bonne chance
0
jeclaude33 Messages postés 185 Date d'inscription mercredi 14 mars 2007 Statut Membre Dernière intervention 18 juin 2022 14 > mamiemando Messages postés 33158 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 21 juin 2024
7 avril 2015 à 20:15
Merci pour tes conseils judicieux; enfin, j'y suis arrivé. J'ai chargé debian8 testing et effectivement la version de skrooge est 1.9.3. J'ai déjà importé mes comptes.
Encore merci, je vais essayé d'étudié tout ça de plus près car je trouve que debian fonctionne mieux que windows et que c'est plus léger.
Bonne soirée.
0
mamiemando Messages postés 33158 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 21 juin 2024 7 760
7 avril 2015 à 21:30
Excellent choix :-) Bravo et bonne continuation !
0