Défusionner ou séparer une cellule en plusieurs.

[Fermé]
Signaler
Messages postés
19
Date d'inscription
lundi 9 mars 2015
Statut
Membre
Dernière intervention
31 janvier 2019
-
 seblg29 -
Bonjour,
Je voudrais connaître une méthode sous excel pour pouvoir transformer une cellule contenant plusieurs informations, non séparées (il s'agit en fait d'une fusion automatique de cellule), afin de les séparer en plusieurs colonnes contenant chacune une information.
exemple :
dans une même cellule je vais avoir 1055 puis en dessous 1056, cependant lorsque je clique dans la barre de formule, les 2 nombres ne sont pas séparés.
je ne trouve aucun moyen pour pouvoir les séparer, pouvez vous m'aider svp ?
sébastien
A voir également:

4 réponses

Messages postés
13120
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 octobre 2021
2 266
Bonsoir

Postes un exemple de ton fichier sur cjoint.com et reviens ici indiquer le lien fourni, ce sera plus évident pour t'aider sans avoir à deviner la structure exacte des cellules
Néanmoins, à priori si une cellule, peut importe qu'elle soit fusionnée ou non, comporte 2 valeurs sur 2 lignes c'est qu'elles sont séparées par un retour à la ligne, alors avec les valeurs par exemple en B3 la formule :
=GAUCHE(B3;TROUVE(CAR(10);B3)-1) renverra la valeur sur le 1ere ligne
et la formule :
=DROITE(B3;NBCAR(B3)-TROUVE(CAR(10);B3)) celle en 2nde ligne

Cdlmnt
Via
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
54871
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
16 775
Simple, net et précis ! Bravo.
Merci beaucoup, je viens d'essayer,
et c'est exactement ce que je recherchais.
Cependant je peux avoir jusqu'à 3 ou 4 nombres dans une même cellule,
quelles sont les formules à utiliser dans ce cas ?
merci d'avance,
sébastien
Messages postés
13120
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 octobre 2021
2 266
Re,

1ere cellule après celle avec les valeurs toujours :
=GAUCHE(B3;TROUVE(CAR(10);B3)-1)
2eme cellule :
=SIERREUR(SI(NBCAR(B3)-NBCAR(SUBSTITUE(B3;CAR(10);""))=1;DROITE(B3;NBCAR(B3)-TROUVE(CAR(10);B3));STXT(B3;NBCAR(C3)+2;TROUVE(CAR(10);B3;TROUVE(CAR(10);B3)+1)-(NBCAR(C3)+2)));"")
3eme cellule :
=SIERREUR(SI(NBCAR(B3)-NBCAR(SUBSTITUE(B3;CAR(10);""))=2;DROITE(B3;NBCAR(B3)-TROUVE(CAR(10);B3;NBCAR(C4)+NBCAR(D4)));STXT(B3;(NBCAR(D3)+NBCAR(C3)+2);TROUVE(CAR(10);B3;(NBCAR(D3)+NBCAR(C3)+2))-(NBCAR(D3)+NBCAR(C3)+2)));"")
4eme cellule :
=DROITE(B3;NBCAR(B3)-(NBCAR(C4)+NBCAR(D4)+NBCAR(E4)+2))

Cdlmnt


et pour la 5eme cellule vous n'auriez pas la formule ?
merci d'avance,
cordialement,
sébastien
ou 5ème nombre dans la même cellule, je me suis mal exprimé..
Messages postés
13120
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 octobre 2021
2 266 > seblg29
Re

Tu commences par ne citer que 2 nombres puis après c'est 3 ou 4, maintenant 5
il faut aller jusqu'à combien ?? Fais une demande précise dès le début, on ne va pas faire 3 travaux ou plus pour un seule demande !!!
Si tu as 5 nombres il faut adapter la formule de la 3eme cellule pour un 4eme nombre et idem pour le 5eme nombre
Mais je m'aperçois que mes formules comportent des erreurs, on les oublie !

En reprenant à la base et en décomposant les étapes avec des formules allégées et plus compréhensibles que tu pourras adapter à ta guise :
https://www.cjoint.com/c/EClaqJ7vih6

Cdlmnt
Via
Re,

Oui c'est vrai que j'aurais pu le demander en une seule fois, je me suis rendu compte seulement lors de l'exploitation de mon fichier que celui-ci contenait une variation de nombre importante.
Merci d'avance,
Cordialement,
Sébastien