Création code automatique

Résolu/Fermé
xav37300
Messages postés
46
Date d'inscription
mercredi 18 décembre 2013
Statut
Membre
Dernière intervention
4 septembre 2019
- 7 mars 2015 à 18:56
xav37300
Messages postés
46
Date d'inscription
mercredi 18 décembre 2013
Statut
Membre
Dernière intervention
4 septembre 2019
- 8 mars 2015 à 16:48
Bonjour,

J'aimerais savoir s'il existe une formule pour pouvoir attribuer un code automatiquement à un article.

J'ai réussi à trouver une formule pour pouvoir l'attribuer mais il faut que tout soit ranger par ordre alphabétique (code = 1er lettre de l'article + 1) alors que si j'ajoute un article il ne me reprend pas mon dernier code et ajoute 1.

Ci joint le fichier https://www.cjoint.com/c/EChtgm5FFD2 avec en couleur ce que je souhaiterai.


Merci pour votre aide




3 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 253
Modifié par Vaucluse le 7/03/2015 à 19:15
Bonsoir

cette formule en B7, à tirer sur la hauteur utile:

=SI(C7="";"";GAUCHE(C7;1)&SOMMEPROD((GAUCHE($C$7:C7;1)=GAUCHE(C7;1))*1))

attention aux signes

et si vous voulez un code à trois chiffres (ou plus à ajuster)

=SI(C7="";"";GAUCHE(C7;1)&TEXTE(SOMMEPROD((GAUCHE($C$7:C7;1)=GAUCHE(C7;1))*1));;000")

crdlmnt

Errare humanum est, perseverare diabolicum
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 938
Modifié par Mike-31 le 7/03/2015 à 19:58
Bonsoir,

En B7

=GAUCHE(C7;1)&NB.SI($C$7:C7;"*"&GAUCHE(C7;1)&"*")

et incrémente vers le bas
En C12 bouteille, faut il traiter la majuscule dans ce cas il faudrait écrire

=MAJUSCULE(GAUCHE(C7;1))&NB.SI($C$7:C7;"*"&GAUCHE(C7;1)&"*")

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
xav37300
Messages postés
46
Date d'inscription
mercredi 18 décembre 2013
Statut
Membre
Dernière intervention
4 septembre 2019

8 mars 2015 à 16:48
Merci beaucoup à vous ca fonctionne très bien
0