Garder format nombre dans fonction concatener [Résolu/Fermé]

Signaler
-
 FVA -
Bonjour,

Je souhaite utiliser la fonction concatener, avec des nombres de 8 chiffres sachant que pour certains nombres les premiers chiffres peuvent être des 0.
Du coup dans ma formule ils disparaissent.

Merci d'avance.



2 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 301
Bonjour,

Avec la fonction concaténer (que tu peux remplacer par '&'), si tu veux conserver certains formats il faut inclure la fonction TEXTE :
=TEXTE(B1;"00000000")&TEXTE(A1;"j/m/aaaa")&TEXTE(C1;"# ##0.00 €")

Ainsi tu as un nombre de 8 chiffres, une date et un montant monétaire.
Toujours zen
La perfection est atteinte, non pas lorsqu'il n'y a plus rien à ajouter, mais lorsqu'il n'y a plus rien à retirer. Antoine de Saint-Exupéry
10
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Merci, ça fonctionne.
Encore merci pour ta rapidité.

Bonne journée
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 733
Bonjour
votre titre est incompatible avec vos explications. Si vous voulez des 0 en tête de concaténation, il faut être en format texte, sinon les 0 disparaissent effectivement.
Pouvez vous donnez un exemple du problème avec le résultat attendu?
à vous lire
C'est tout bon, je voulais concatener un lien sur mon disque avec un nombre(Référence de pièces).
Gbinforme m'a résolu le problème.

Merci