Copier fichiers avec toutes leurs propriétés [Résolu/Fermé]

Signaler
Messages postés
615
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
13 novembre 2020
-
Messages postés
615
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
13 novembre 2020
-
Bonjour,
Je suis confronté à un problème que je qualifierais d'étrange.
Sur mon ordinateur, tout fonctionne à merveille. Mais pas sur celui de ma collègue.
Explications :
J'ai un fichier avec macros faisant appel à une base de données se trouvant dans le même dossier que le fichier principal. Sur mon PC, pas de problème, le fichier principal me trouve la bdd et je peux m'en servir. Je peux utiliser tous les boutons.
Le fichier terminé, je l'ai envoyé à ma collègue, mais ça ne fonctionne pas. Pas du tout.
Nous utilisons tous les deux Excel 2010.
Je me demande s'il peut y avoir un soucis au niveau des paramètres d'Excel sur son PC.
Quelqu'un aurait une idée d'où peut venir le problème ?

Le fichier : https://www.cjoint.com/c/EBvlxpjC09y
La base de données : https://www.cjoint.com/c/EBvlxGiV6Ms

Merci infiniment !


5 réponses

Messages postés
7102
Date d'inscription
jeudi 13 septembre 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
580
L'erreur vient du fait que ta bdd est nommée:

"bdd.xlsx"

ce qui fait que dans ThisWorkBook, il faut mettre ceci:

  Workbooks.Open ThisWorkbook.Path & "\bdd.xlsx.xlsx"


ou tout simplement renommer ta bdd:
bdd
@+ Le Pivert
Messages postés
615
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
13 novembre 2020
49
Merci pour ta réponse, mais ça ne fonctionne pas.
J'ajouterais même, sur mon ordinateur ça fonctionne à merveille.

Non seulement il ne trouve pas la bdd, alors qu'elle se trouve où il faut, mais en plus j'ai le débogeur qui n'est pas content lorsque je souhaite "ajouter une ligne enfant", j'ai ceci de surligné :
    ActiveSheet.Unprotect "alsh" 'Retirer la protection

Le mot de passe est pourtant le bon...

J'ai également un message d'erreur au survol de "Rechercher un enfant" :
"Impossible de sortir du mode création, le contrôle 'ListBox1' ne peut pas être crée"
Je ne comprend plus rien :O
Le mode création n'est pas activé pourtant...

Bien à vous,
Naï
ps: je surveille tous mes sujets non résolus, si solution vous avez, je la lirais à coup sûr :)
Messages postés
7102
Date d'inscription
jeudi 13 septembre 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
580
Fonctionne très bien chez moi sous Excel 2007:

http://www.cjoint.com/data3/3BvqXC3q4K0.htm
Messages postés
615
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
13 novembre 2020
49
Pas chez moi sous Excel 2010.
Le problème doit venir des paramètres d'Excel de ma collègue.
Je compare ses paramètres aux miens tout de suite.
Si le problème venait de là, ça risque de me poser un énorme problème. Même si j'ai accès à l'ordinateur de ma collègue, le fichier a vocation à être utilisé par d'autres directeurs, sur d'autres ordinateurs, auxquels je n'aurais pas accès.
M'enfin, je vais voir de ce côté.
Messages postés
615
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
13 novembre 2020
49
Mes paramètres sont identiques à ceux de ma collègue. Je ne comprend pas...
Messages postés
615
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
13 novembre 2020
49
Le fichier semble fonctionner désormais sur le PC de ma collègue.
Une mise à jour ? Qui sait...