Calcul avec condition soumis a un intervalle sur excel [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
jeudi 22 janvier 2015
Statut
Membre
Dernière intervention
3 février 2015
-
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
-
Bonjour j'ai besoin de faire un tableau sur excel pour calculer les tarifs liés a de la consommation d'électricité soumis a des tranches d'utilisation.
Par exemple :Pour la consommation énergétique d'un même matériel nous disposons de 3 tranche d'utilisations:

-1ére tranche de 0kw a 50 Kw = on multiplie la puissance consommé P par un tarif X1
-2éme tranche de 51Kw a 150Kw = on multiplie la puissance consommé P par un tarif X2
-3éme tranche de plus 150Kw = on multiplie la puissance consommé P par un tarif X3

Quelle matrice puis-je utiliser pour qu'a chaque fois que je mets dans mon tableau la puissance consommé P (P=1000) pour que cela me calcule directement le cout de la consommation dépendamment des différentes tranches d'utilisations et de leur tarification.

MERCI D'AVANCE POUR AIDE

3 réponses

Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Bonjour

votre demande peut se traiter de deux façons:

soir le tarif s'applique à toute la tranche selon sa valeur

dans ce cas, la formule:

=SI(A2<=50;A2*X1;SI(A2<=150;A2*X2;A2*X3))

soit il faut appliquer le tarif correspondant aux premières tranches, ce qui donne

exemple à adapter
colonne A consommation / colonne B montant, à partir de ligne 2

D'abord calculer les constantes "plafond" de chaque tranche

prix de la 1° tranche complète: en cellule C1=50*X1
prix de la seconde tranche : en cellule C2=(150-50)*X2+C1

autant calculer ces montants qui vont être fixe dans la, formule:

la formule en B2:

=SI(A2<=50;A2*X1;SI(A2<150;$C$1+(A2-50)*X2;$C$^2+(A2-150)*X3))


attention aux signes $ sur les adresses C

Note: en plaçant les tarifs X1/2:3 dans un tableau de référence, pour pouvez les modifier sans reprendre les formules

crdlmnt

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
jeudi 22 janvier 2015
Statut
Membre
Dernière intervention
3 février 2015

MERCI :):):) sa a fonctionné avec la méthode des plafonds en fixant dans la formule les plafonds...

Voici la formule adapté avec C8 et C9 comme étant les plafonds et C5 C6 C7 les 3 tarifs respectivement. J5 étant la consommation.

=SI(J5<=50;J5*$C$5;SI(J5<150;$C$8+(J5-50)*$C$6;$C$9+(J5-150)*$C$7))

MERCI ENCORE
Messages postés
25378
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2020
5 526
Pas de quoi, je passe le sujet en résolu.
Bonne route
crdlmnt