Somme colonnes avec texte [Résolu/Fermé]

Signaler
-
 Belnadifia -
Bonjour,

J'ai dans mon tableau excel une colonne A1:A10 contenant un date, et un prix.
exemple :

A1 = "29/12 | 60€"
A2 = "31/08 | 250€"
A3 = "6/10 | 2500€"
[...]

Et en A11 j'aimerai avoir la somme de tous les prix de cette colonne (donc 60+250+2500...)

Avec [STXT(A1:A10;TROUVE("| "; A1:A10)+2;10) j'arrive a avoir {#VALEUR!;#VALEUR!;"60€";250€";"2500€".....} donc on voit qu'il arrive à isoler les chiffres, mais ne les additionne pas ...

Avez vous une idée de comment je pourrai y parvenir ?

4 réponses

Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
Bonjour
le plus simple serait de créer une colonne qui ne renvoie que la valeur numérique et d'en faire la somme, avec cette formule à tirer sur la hauteur utile:

=DROITE(A1;NBCAR(A1)-TROUVE(" ";A1;1))*1

à condition bien sur que la date et le montant soient au moins séparées par in blanc

crdlmnt

ps ou alors, sans colonne supplémentaire, cette formule en matricielle (exemple ,de A1 à A100:

=SOMMEPROD((SI(A1:A100<>"";DROITE(A1:A100;NBCAR(A1:A100)-TROUVE(" ";A1:A100;1))*1)*1))

Formule à entrer avec la touche ENTER en maintenant ctrl et shift enfoncées, elle doit se retrouver entre accolades dans la barre de formule

Exemple à l'appui:
https://www.cjoint.com/c/EAwsHzfowAs

Errare humanum est, perseverare diabolicum
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 437
Bonsoir le fil,

ou toujours en formule matricielle qu'il faudra valider en pressant en même temps sur les trois touches du clavier Ctrl, Shift et Entrée, si tu fais bien la formule se placera entre {}

la formule somme moins gourmande en ressource

=SOMME(SI(A1:A100<>"";DROITE(A1:A100;NBCAR(A1:A100)-TROUVE("| ";A1:A100;1))*1)*1)

ou la formule actualisée de l'ami Vaucluse que je salue,

=SOMMEPROD((SI(A1:A100<>"";DROITE(A1:A100;NBCAR(A1:A100)-TROUVE("| ";A1:A100;1))*1)*1))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
25761
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
5 726
Salut Mike
tu as probablement raison, moi j'ai cru que le signe l n'était là que pour présenter les données dans le message.
Au plaisir
Bien cordialement
Je vous remercie pour vos informations qui résolve mon problème :)
J'ai choisi la formule moins gourmande en ressource, mais les 2 fonctionnes, merci.

Me reste maintenant a déchiffrer le tout pour ne pas me coucher bête ^^
Messages postés
1147
Date d'inscription
lundi 10 mai 2010
Statut
Membre
Dernière intervention
26 décembre 2020
97
Bonjour,

Franchement, le mieux est de faire deux colonnes. Enfin si tu peux
malheureusement, ce n'est pas possible
C'est pour ca que je cherche un moyen de le faire, sinon effectivement je ne me serai pas embêté :)