Petit problème casse tête sur excel ^^

Résolu/Fermé
clement94
Messages postés
5
Date d'inscription
vendredi 12 octobre 2012
Statut
Membre
Dernière intervention
21 janvier 2015
- Modifié par clement94 le 20/01/2015 à 11:25
clement94
Messages postés
5
Date d'inscription
vendredi 12 octobre 2012
Statut
Membre
Dernière intervention
21 janvier 2015
- 21 janv. 2015 à 16:35
Bonjour, Je vous expose mon problème
Je suis en stage en entreprise et j'ai une mission, un tableau excel avec des colorants en lignes (E100, E102 ...) dans les colonnes j'ai des couleurs (bleu, vert...) que l'on réalise grâce aux colorants.
Je possède ensuite un 2ème tableau avec en ligne les mêmes colorants que précédemment et en colonne des continents (EUROPE, USA ...) à l'intérieur de nos 2 tableaux il y a des 1 et des 0 désignant la présence ou non des colorants soit dans les pays soit dans une couleur.

Ma mission est de faire 1 tableau qui nous indiquera les couleurs que les pays pourront commercialiser en fonction des colorants autorisés dans le pays.

Rien de bien complexe avec une simple fonction SI
J'obtiens : =SI(M19=0;"A MOFIER";SI(X19=0;"A MODIFIER";"OK"))
En gros pour la couleur blanche j'ai besoin de E132 et de E171 je teste si dans les pays ces 2 colorants sont autorisés si oui "OK" si non on doit "MODIFIER".

Et là vient mon réel problème, si je veux faire un tableau se mettant correctement à jour il faudrait que je crée un grand si imbriqué (17 colorants) et que cette fonction vérifie chaque colorant de la ligne pour la couleur blanche et dès qu'il trouve un numéro 1 qu'il vérifie dans le tableau des pays si ce colorant est bel et bien autorisé.

j'ai fait cette ébauche:
=SI(C5=1;SI(C19=0;"A MOFIER";SI(D5=1;SI(D19=0;"A MOFIER";SI(E5=1;SI(E19=0;"A MOFIER";"Faux"))))))+SI(E6=1;SI(E19=0;"A MOFIER";"Faux")) ...

Bon, elle ne marche pas encore mais je pense que c'est à peu près l'idée.

Merci d'avance pour votre aide et bon courage pour ce casse tête ^^

Clément

8 réponses

DjiDji59430
Messages postés
3530
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
19 mai 2022
532
20 janv. 2015 à 18:43
Bonjour,

J'ai poursuivi mon effort, avec les nouvelles donnes.

https://www.cjoint.com/c/EAusZKTxSEh

Ça doit surement se faire en macro, mais je ne sais pas !
1
JvDo
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
849
Modifié par JvDo le 20/01/2015 à 21:22
Bonsoir à tous,

une proposition :

1) créer des noms pour que la formule soit plus parlante :
composition =Feuil1!$B$2:$AA$9
règlementation =Feuil1!$B$17:$AA$45

2) mettre des 0 dans le tableau composition à la place des cellules vides.

3) sélectionner la zone AC17:AJ45 et saisir la formule :
=SI(PRODUITMAT(règlementation;TRANSPOSE(composition))=TRANSPOSE(PRODUITMAT(composition;--STXT(REPT("1";COLONNES(composition));LIGNE(INDIRECT("$1:$"&COLONNES(composition)));1)));"x";"")


4) valider par CTRL+MAJ+ENTER

5) mettre en AC16:AJ16 les titres des colonnes avec les couleurs "blanc bleu rose vert jaune peche dune café"

6) si nécessaire, faire une zone de filtre sur ces couleurs pour identifier les pays en fonction des couleurs.


cordialement
1
DjiDji59430
Messages postés
3530
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
19 mai 2022
532
21 janv. 2015 à 10:15
Bonjour,

revu, plus simple que la v2

https://www.cjoint.com/c/EAvkwSUkCKq
1
michel_m
Messages postés
16568
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
14 mai 2022
3 279
20 janv. 2015 à 11:32
Bonjour,

mettre le classeur sans données confidentielles en pièce jointe sur https://www.cjoint.com/
et coller le lien proposé dans le message de réponse
Dans l'attente

0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
clement94
Messages postés
5
Date d'inscription
vendredi 12 octobre 2012
Statut
Membre
Dernière intervention
21 janvier 2015

20 janv. 2015 à 12:06
0
DjiDji59430
Messages postés
3530
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
19 mai 2022
532
20 janv. 2015 à 12:42
Bonjour,

Un essai en feuille 2 (a compléter si accepté)

https://www.cjoint.com/c/EAumYi1xgMA
0
clement94
Messages postés
5
Date d'inscription
vendredi 12 octobre 2012
Statut
Membre
Dernière intervention
21 janvier 2015

20 janv. 2015 à 14:19
Merci beaucoup ! mais la formule indiquée dans la pièce jointe me semble être un substitut de celle que j'avais indiqué dans l'explication du sujet :
=SI(M19=0;"A MOFIER";SI(X19=0;"A MODIFIER";"OK"))
néanmoins votre formule est bien mieux faite !

Le problème est que cette base de données est appelée à être modifiée (les 1 et 0 dans le tableau des colorants nécessaires pour créer une couleur) il me faudrait donc une formule qui, si pour produire la couleur blanche nous n'avons plus besoin de 100, 144, 148 par exemple mais de 100, 144, 114 et sachant que le 114 est interdit en Europe il devrait alors y avoir modification automatique dans le tableau de synthèse qui indiquerait qu'en Europe la couleur blanche serait interdite.

Merci beaucoup pour ces réponses rapides c'est super !
0
clement94
Messages postés
5
Date d'inscription
vendredi 12 octobre 2012
Statut
Membre
Dernière intervention
21 janvier 2015

21 janv. 2015 à 16:35
Merci beaucoup pour vos réponses c'est top ! JvDO c'est top ton système mais j'avoue que l'idée de djidji59430 et vraiment super simple avec l'addition des 1 devant être égale au nombre de 2 ! Je vais pouvoir finir ça maintenant merci encore et à bientôt sur le forum surement :D !
0