Excel : Fonction SOMMEPROD - question [Résolu/Fermé]

Signaler
-
 Fabbe -
Bonjour,


Je viens chercher votre aide sur base d'un problème de statistiques sur lequel je suis bloqué..
En effet, voici un exemple de ma base de données :


00 Col.A -Col.B -Col.C


01 18,25 Brux. 25/04/2009
02 32,15 Brux. 16/09/2009
03 20,69 Brux. 08/09/2009
04 21,71 Fland. 12/12/2009
05 42,32 Fland. 01/02/2010
06 55,01 Wallo. 30/06/2009
07 19,88 Brux. 02/01/2010
08 29,16 Wallo. 01/09/2009
09 36,78 Brux. 14/01/2010
10 40,99 Fland. 15/05/2009


La Colonne A correspond à l'âge des personnes;
La Colonne B correspond à leur région de domicile (vous aurez compris, je suis belge :) );
La Colonne C correspond à une date(dont je vous épargne le pourquoi, ce serait trop long...)


Je souhaiterais obtenir le résultat statistique du nombre de personnes entre 18 et 25 ans domiciliés à "Brux." et dont la date de la Colonne C est compris en 2009 (01/01/2009 à 31/12/2009). Le résultat devrait donc être : 2.


Concernant les 2 dernières informations, j'utilise la formule suivante :


=SOMMEPROD((C2:C10>=DATEVAL("1/01/2009"))*(C2:C10<=DATEVAL("31/12/2009"))*(B2:B10="Brux."))


Par contre, je ne vois pas comment insérer les tranches d'âge dans cette formule SOMMEPROD...


De manière générale, j'utilise pour les tranches d'âge la formule suivante :


=NB.SI(A2:A10;">=18,00")-NB.SI(A2:A10;">=25,00")


Auriez-vous la bonté de m'aider sur cet épineux (et important) problème (pour moi :) ) ?


Merci d'avance de vos retour et solutions!

Fabbe

5 réponses

Messages postés
12251
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
17 mars 2021
2 593
Bonjour,

Regarde cette formule :
=SOMMEPROD((ANNEE(C1:C10)=2009)*(B1:B10="Brux.")*(A1:A10>=18)*(A1:A10<=25))
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 397
Bonjour pijaku,

Bonne année en passant : je n'avais pas vu ta réponse.
Messages postés
12251
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
17 mars 2021
2 593 >
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020

Salut,

Merci et bonne année à toi également.

A+
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 397
Bonjour,

Tu insères ton age comme la date :

=SOMMEPROD((A2:A11>=18)*(A2:A11<=25)*(C2:C11>=DATEVAL("1/01/2009"))*(C2:C11<=DATEVAL("31/12/2009"))*(B2:B11="Brux."))

Bonjour gbinforme,
Bonjour pijaku,

Je vais tester vos propositions de ce pas !

Merci bcp :)
Re-bonjour,

Parfait! C'est parfait :)

Dites, j'en profite pour une autre question toujours sur SOMMEPROD

J'ai la formule de base ci-dessous qui me permet de trouver une cellule dans laquelle est mentionnée le terme " NON ":

=NB.SI(S2:S10;"*NON*")

Si je souhaite ajouter comme notion le fait que ce soit un Bruxellois, la formule suivante ne fonctionne pas :

=SOMMEPROD((S2:S10="*NON*")*(P2:P10="Brux."))

Pouvez-vous me dire où est mon erreur ?

Encore un grand merci pour l'aide précédente, et à l'avance pour cette aide-ci :)

A++

Fabbe
Messages postés
12251
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
17 mars 2021
2 593
SOMMEPROD n'accepte pas les caractères génériques (* et ?).
Essaye cette formule de Jacques boisgontier (il me semble) :
=SOMMEPROD((ESTNUM(TROUVE("NON";S2:S10)))*(B2:B10="Brux."))
Cela a l'air de fonctionner également :)

Un grand merci !!!

++