[Excel 2013] Remplacer des valeur par rapport à un interval [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mardi 4 décembre 2012
Statut
Membre
Dernière intervention
27 décembre 2014
-
Messages postés
2
Date d'inscription
mardi 4 décembre 2012
Statut
Membre
Dernière intervention
27 décembre 2014
-
Salut @ tous , ;)





--

5 réponses

Messages postés
25306
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2020
5 483
Bonjour
si la liste commence en A1, en B1:

=SI(A1="";";SI(A1<36=36;1;SI(A1<=50;2;3)))

sauf erreur de compréhension, ce qui reste possible.

crdlmnt
Messages postés
12690
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 septembre 2020
2 024
Bonsoir

En supposant les 450 valeurs (avec aucune valeur inférieure à 21) en colonne A à partir de A2, en B2 la formule :
=si(A2<=36;1;SI(A2>50;3;2))

Cdlmnt
Messages postés
5508
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 septembre 2020
485
Bonjour

Essayer cette formule, l'âge étant en A1 dans mon exemple

=SI(ET(A1>=21;A1<=36);1;SI(ET(A1>=37;A1<=50);2;SI(ET(A1>=51;A1<=70);3;"")))

Ne sachant pas s'il y des moins de 21 ans et des plus de 70 ans je vous ai mis tous les contrôles

C'est en forgeant que l'on devient forgeron. - C'est au pied du mur que l'on voit le maçon - on apprend toujours de ses erreurs
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 249
Bonsoir,

et si j'ai également bien compris la demande peut être comme ça

=SI(A1>50;3;SI(A1>36;2;SI(A1>=21;1;"")))
Messages postés
2
Date d'inscription
mardi 4 décembre 2012
Statut
Membre
Dernière intervention
27 décembre 2014

--Merci pour tous qui a rependu d'après vos repense maintenant je sais comment utiliser la Fonction SI


Merci infiniment :) :) ;) ;)