Excel 2010 - Somme SI doublons

Résolu/Fermé
Signaler
-
 gestion59 -
Bonjour,

Je cherche depuis quelques temps une solution à un problème, qui me parait gérable, mais pas pour mon niveau ;-)

Je cherche à faire une somme lorsque des critères sont présents plusieurs fois.

Exemple : en colonne A, j'ai des numéros de contrats.
En colonne F, j'ai un montant de remboursement.

Un contrat peut avoir bénéficier de plusieurs remboursements.

Ma question est la suivante : est-il possible de voir n'apparaitre un numéro de contrat qu'une fois mais avec, en colonne F, le montant total des remboursements que ce contrat a pu engendrer.

Ex :
Colonne A Colonne F
1025 110
1026 100
1458 10
1457 58
1457 30
1025 19
1026 24

Résultat souhaité
Colonne A Colonne F
1025 129
1026 124
1458 10
1457 88

Merci d'avance pour votre contribution à mon édifice :)

Bonnes fêtes d'années par avance à toutes et tous !!

Excel 2010

5 réponses

Messages postés
10192
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
4 décembre 2021
2 256
Bonjour

Peut être comme ça
https://www.cjoint.com/?3LcrrvAzBas

RQ. I2 : Formule matricielle à valider avec Ctrl+maj+entree

Cdlmnt
Bonjour CCM81,

J'ai testé votre réponse ce matin. Ca a bien fonctionné sur la première ligne, par contre quand je fais glisser la formule ça ne fonctionne plus, il me met plusieurs fois le même critère de la colonne A...
Il me met autant de fois le critère qu'il n'en existe dans la colonne A
Messages postés
10192
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
4 décembre 2021
2 256
Tu n"as pas lu la remarque.
Une fois validée avec Ctrl+maj+entrée la formule doit se mettre toute seule entre accolades
>
Messages postés
10192
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
4 décembre 2021

Effectivement, je n'avais pas tilté sur cette subtilité !

Merci à vous !
Messages postés
13222
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
5 décembre 2021
2 292
Bonjour

1° copier la colonne A de la feuille 1 et la coller en colonne A (à partirde A2 par ex) d'une feuille 2
2° selectionner cette colonne en feuil 2 puis Données Supprimer les doublons
3° en B2 de cette feuille 2 mettre la formule =SOMME.SI(Feuil1!A:A;A2;Feuil1!F:F)
4° etire la formule vers le bas

Cdlmnt

"L'imagination est plus importante que le savoir." A. Einstein
Messages postés
5730
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
5 décembre 2021
677
Bonjour

Sur la colonne F pas possible
Mais en G faisable avec cette formule

=SI(NB.SI($A$1:$A1;$A1)=NB.SI($A$1:$A100;$A1);SOMME.SI($A$1:$A$100;$A1;$F$1:$F$100);"")
Je regarde vos réponses dans la journée, désolé je n'avais pas vu ces réponses hier.
Je vous remercie d'avance pour votre sympathie en tout cas
Messages postés
16538
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 décembre 2021
3 252
Bonjour,

Sans te prendre la tête avec des formules, cela se fait en 5 minutes avec un TCD (Tableau Croisé Dynamique)

Si tu ne connais pas cette b^te là, tu trouveras comment faire sur ce site très complet

http://boisgontierjacques.free.fr/
Merci Michel, la formule sur la première réponse fonctionne parfaitement.
Merci à tous pour votre aide !