Bug sur formule pour faire une moyenne sur 2 ou 3 chiffres

Résolu/Fermé
margoulette2 Messages postés 4 Date d'inscription samedi 22 novembre 2014 Statut Membre Dernière intervention 24 novembre 2014 - Modifié par margoulette2 le 22/11/2014 à 21:23
margoulette2 Messages postés 4 Date d'inscription samedi 22 novembre 2014 Statut Membre Dernière intervention 24 novembre 2014 - 24 nov. 2014 à 21:17
Bonjour,

j'ai un soucis de formule

Sur un tableau je dois faire une moyenne sur 2 ou 3 chiffres, j'ai donc intégrer la formule pour que ca me calcul la moyenne de 3 chiffres maximum

cependant lorsque le dernier =0 ma moyenne des 2 premiers est fausse !
lorsque le 3ème est >0 la moyenne des 3 est juste
et lorsque j'efface le 0 la moyenne des 2 premiers est juste !!!

y a-t-il une solution ? ca me faciliterai la vie de tout les jours

merci de votre aide


En image :


exemple 1 faux car je devrais trouver : 5.60

N° serie Prix Prix serie Moyenne

123 3,00 0 4,73
124 8,20
125 0,00


Exemple 2 juste mais je suis obligé de supprimer le 0 du n°125

N° serie Prix Prix serie Moyenne

123 3,00 0 5.6
124 8,20
125



Exemple 3 juste car les 3 valeurs sont >0

N° serie Prix Prix serie Moyenne

123 3 0 4,90
125 8,2
126 3,5



formule utilisée :

=SI(S22>0;(MOYENNE(S21:S23)))




2 réponses

f894009 Messages postés 16713 Date d'inscription dimanche 25 novembre 2007 Statut Membre Dernière intervention 3 octobre 2022 1 655
Modifié par f894009 le 23/11/2014 à 10:23
Bonjour,

ex: changer les plages

=MOYENNE.SI(A1:A4; ">0")

=MOYENNE.SI.ENS(A1:A4; A1:A4;">0")
0
margoulette2 Messages postés 4 Date d'inscription samedi 22 novembre 2014 Statut Membre Dernière intervention 24 novembre 2014
24 nov. 2014 à 17:57
Bonjour F894009

super gentil merci ca fonctionne !!!

fini la galère

merci encore

bonne soirée
0
margoulette2 Messages postés 4 Date d'inscription samedi 22 novembre 2014 Statut Membre Dernière intervention 24 novembre 2014
24 nov. 2014 à 18:02
je ne sais pas comment mettre que le prb est résolu

merci
0
jordane45 Messages postés 36372 Date d'inscription mercredi 22 octobre 2003 Statut Modérateur Dernière intervention 2 octobre 2022 4 366 > margoulette2 Messages postés 4 Date d'inscription samedi 22 novembre 2014 Statut Membre Dernière intervention 24 novembre 2014
24 nov. 2014 à 18:46
En cliquant sur le lien "marquer comme résolu" sous le titre de ta question.
=> Je le fais pour toi.
0
margoulette2 Messages postés 4 Date d'inscription samedi 22 novembre 2014 Statut Membre Dernière intervention 24 novembre 2014
24 nov. 2014 à 21:17
ok merci
0