[Excel] Formule avec chiffres et du texte

[Résolu/Fermé]
Signaler
Messages postés
12
Date d'inscription
vendredi 8 juin 2007
Statut
Membre
Dernière intervention
10 juillet 2007
-
Messages postés
12
Date d'inscription
vendredi 8 juin 2007
Statut
Membre
Dernière intervention
10 juillet 2007
-
Bonjour,

Je dois créer une formule assez complexe (pour moi) :)

Après plusieurs tentatives je n'y arrive pas.

J'ai 9 cellules (AO4,AO6,AO8,AO10,AO12,AO14,AO16,AO18, AO20) dans une colonne. Jusque là tout va bien! :)

Chaque cellule peut contenir un chiffre, du texte ou rien. J'utilise "Données - validations" pour pouvoir choisir sous forme de menu déroulant la valeur de la cellule.

Exemple:

AO4 peut avoir comme valeur:

"" -> Rien
2,5 -> Chiffre
NO -> Texte

Dans la cellule AO22, je souhaite obtenir une formule de ce style:

Si(AO4,AO6...,AO20)=ESTVIDE Alors AO22=""
Sinon
Si(AO4,AO6...,AO20)=(ESTNUM OU ESTTEXTE) Alors AO22=1
Sinon
Si(AO4; OU(AO6); OU(A08);OU,...,; OU(AO20)=ESTVIDE Alors AO22=2

Pour résumer, si toutes les cellules sont vides je voudrais la cellule AO22 vide
si toutes les cellules ont des chiffres ou du texte je voudrais la cellule AO22=1
si une ou plusieurs cellules sont vides je voudrais que AO22=2

Avez-vous la solution à mon problème? J'ai surtout des problèmes au niveau de la syntaxe.

Merci pour votre aide!

2 réponses

Bonsoir,

Pour plus de clarté dans la formule, je te conseille de nommer la plage de cellules. Dans l'exemple ci-dessous, "Liste" correspond à AO4;AO6;AO8...AO20 et voici la formule :

=SI(NBVAL("Liste")=0;"";SI(NBVAL("Liste")=9;1;2))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
12
Date d'inscription
vendredi 8 juin 2007
Statut
Membre
Dernière intervention
10 juillet 2007
2
Merci fred, j'ai suivi ta logique et j'y suis arrivé!