Si et ou imbriqué (2010)

Résolu/Fermé
louloute750 Messages postés 14 Date d'inscription mercredi 17 septembre 2014 Statut Membre Dernière intervention 11 mars 2015 - 9 nov. 2014 à 10:03
louloute750 Messages postés 14 Date d'inscription mercredi 17 septembre 2014 Statut Membre Dernière intervention 11 mars 2015 - 9 nov. 2014 à 10:54
bonjour,

Je dois modifier les formes juridiques en colonne AC avec les sigles appropriés :

SA Conseil Administration= SA
Société Anonyme=SA
S.A. à Directoire =SA
SA Directoire & Conseil Surv.=SA

Association sans but lucratif=ASSOCIATION
Sté en commandite simple=SCS
Sté par Action Simplifiée = SAS
S.A.R.L.=SARL
Sté Coop Ouvrière Production=STE COOPERATIVE
Sté en commandite par actions=SCS


donc j'ai mis la formule suivante mais j'ai un message d'erreur "VALEUR"

SI(OU(AC5="SA Conseil Administration";"Société Anonyme";"S.A. à Directoire";"SA Directoire & Conseil Surv.");"SA";SI(AC5="Association sans but lucratif";"ASSOCIATION";SI(AC5="Sté en commandite simple";"SCS";SI(AC5="Sté par Action Simplifiée";"SAS";SI(AC5="S.A.R.L.";"SARL";SI(AC5="Sté Coop Ouvrière Production";"STE COPERATIVE";SI(AC5="Sté en commandite par actions";"SCS")))))))

HELP

Merci par avance
A voir également:

2 réponses

Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 063
Modifié par Mike-31 le 9/11/2014 à 10:46
Bonjour,

Regarde comme cela

=SI(OU(AC5="SA Conseil Administration";AC5="Société Anonyme";AC5="S.A. à Directoire";AC5="SA Directoire & Conseil Surv.");"SA";SI(OU(AC5="Sté en commandite simple";AC5="Sté en commandite par actions");"SCS";SI(AC5="Association sans but lucratif";"ASSOCIATION";SI(AC5="Sté par Action Simplifiée";"SAS";SI(AC5="S.A.R.L.";"SARL ";SI(AC5="Sté Coop Ouvrière Production";"STE COOPERATIVE";""))))))

mais tu aurais intérêt à créer une petite base de données sur deux colonnes que tu pourras masquer exemple A2:B11

SA Conseil Administration SA
Société Anonyme SA
S.A. à Directoire SA
SA Directoire & Conseil Surv. SA
Association sans but lucratif ASSOCIATION
Sté en commandite simple SCS
Sté par Action Simplifiée SAS
S.A.R.L. SARL
Sté Coop Ouvrière Production STE COOPERATIVE
Sté en commandite par actions SCS

et utiliser une RECHERCHEV ce qui te permettra facilement de modifier ta base sans avoir à modifier ta formule
et En colonne AC tu crée des liste de validation pour avoir à simplement sélectionner l'intitulé

du style
=RECHERCHEV(AC5;A2:B11;2;0)
si tu nommes ta plage A2:B11 exemple List, la formule peut être utilisée facilement sur des onglets autre et devient
=RECHERCHEV(AC5;List;2;0)

tu peux également compléter la formule avec un gestion d'erreur

=SIERREUR(RECHERCHEV(AC5;List;2;0);"")
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
louloute750 Messages postés 14 Date d'inscription mercredi 17 septembre 2014 Statut Membre Dernière intervention 11 mars 2015
9 nov. 2014 à 10:54
Merci Mike la formule fonctionne enfin, je suis restée bloquée sans penser à rajouter AC5 à chaque fois, ce qui en soit est logique....

l'idée de la RECHERCHEV n'est pas mal non plus et plus pratique

Encore merci pour tous ces conseils

Louloute750
0