Moyenne avec cellule contenant des formules

[Résolu/Fermé]
Signaler
Messages postés
87
Date d'inscription
lundi 27 octobre 2014
Statut
Membre
Dernière intervention
3 septembre 2018
-
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
-
Bonjour,

Je cherche à calculer une moyenne de 12 cellules dont les valeurs correspondent déjà au résultat d'une formule, sans tenir compte des cellules pour lesquelles les valeurs ne sont pas calculées, mais contenant quand même la formule.
Par exemple, sur mes 12 cellules, j'en ai juste 6 qui ont obtenues une valeur numérique, et les 6 autres, c'est juste la formule.
J'ai essayé plusieurs formules que j'ai trouvé sur ce forum, mais aucune ne marche. En fait, les cellules sont ni vide, ni égales à 0.
Que dois-je faire ?

Merci d'avance

6 réponses

Messages postés
54683
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
16 595
Bonjour.

Que dois-tu faire ? En priorité nous envoyer ton fichier, avec tes formules actuelles.
Va dans https://www.cjoint.com/ pour créer le lien, que tu reviendras coller ici.
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061
Bonjour
curieuse question
en principe, la fonction MOYENNE(champ) ne prend en compte que les valeurs numériques quelques soient les autres
exemple
A1=1
A2=A
A3=1
A4=1
A5=X
A6=1
=MOYENNE(A1:A6) renvoie bien 1 et non 1/6

pouvez vous en dire plus
Messages postés
87
Date d'inscription
lundi 27 octobre 2014
Statut
Membre
Dernière intervention
3 septembre 2018

Et voilà :
https://www.cjoint.com/?3JBsICQFwdW
Ca devrait marcher.
En fait, c'est pour les cellules U71@U82.
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061
Re

en fait, il faut éliminer le calcul quand la cellule R en ligne est vide car M/OYENNE.SIU n'a rien à calculer
et donc commencer par en U71:

=SI(R71="";"";MOYENNE.SI(A4:A34;R71;I4:I34))

qui éliminera les dièses de #DIV/0! quand R est vide

une autre remarque: est il normal que A4:A34 et I4:I34 ne soit pas bloqués et se décalent quand on descend la formule?

en fait pour pouvoir la tirer directement vers le bas sans la réécrire il faut écrire en U71:

=SI(R71="";"";MOYENNE.SI($A$4:$A$34;R71;$I$4:$I$34))
les signes $ bloquant les adresses des cellules sur :ligne et colonne
pour mémoire:
$A1 colonne bloquée
A$1 ligne bloquée
$A$1 blocage complet


crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
882
Salut le Forum

Tu auras une erreur si R71 n'est pas dans la liste (Exemple 7)

Mytå
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
882
Salut le Forum

Formule en U71 à recopier vers le bas
=SIERREUR(MOYENNE.SI($A$4:$A$34;R71;$I$4:$I$34);"")


Mytå
Messages postés
87
Date d'inscription
lundi 27 octobre 2014
Statut
Membre
Dernière intervention
3 septembre 2018

ho my god, et ben voilà...
wow... merci grandement pour votre aide.
Et les $ pour bloquer lignes et colones.... si j'avais su avant hahaha
Vraiment efficace ce forum... et rapide en + de ça !!!!

Cordialement,
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061
alors en prime, dans la barre de formule, placez le curseur une adresse de cellule et touche F4 successivement pour affecter le blocage voulu.
Je passe le sujet en résolu
Bonne route
crdlmnt