[Tableur] opération sur cases en fonction de la colonne d'à côté [Résolu/Fermé]

Signaler
Messages postés
1143
Date d'inscription
lundi 22 mars 2010
Statut
Membre
Dernière intervention
31 juillet 2019
-
Messages postés
1143
Date d'inscription
lundi 22 mars 2010
Statut
Membre
Dernière intervention
31 juillet 2019
-
Salut !

J'ai une colonne avec des nombres et une colonne qui contient parfois le mot Non.
Je souhaiterais afficher la somme des nombres dont la case d'à côté contient Non.

Comment faire ?

Il faudrait faire une boucle pour vérifier une à une les cases de la colonne et si elle contient Non alors on ajoute à la somme le contenu de la case voisine. Mais peut-on seulement faire une boucle dans une formule de tableur ?
Merci !

PS : j'utilise LibreOffice (LibO) 4.2.6

3 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 255
Bonjour,

Avec tes nombres en A1:A20 et "non" en B1:B20, tu mets cette formule :

=SOMMEPROD((B1:B20="non")*A1:A20)

Les nombres de la colonne A sont cumulés si la colonne B est à "non".
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
817
Salut le Forum

Un SOMME.SI est suffisant
=SOMME.SI(B1:B20;"non";A1:A20)

Mytå
Messages postés
1143
Date d'inscription
lundi 22 mars 2010
Statut
Membre
Dernière intervention
31 juillet 2019
102
C'est génial !
Enfin, c'est mauvais pour mon budget, mais c'est génial ! :P

SI j'ai bien compris, l'expression booléenne permet de ne pas compter s'il n'y a pas nom car 0*x=0. C'est astucieux... :)
Comme je connais très mal la notion de matrice je n'aurais pas trouvé seul.

Merci beaucoup !

Seul truc (très peu gênant) : j'ai fusionné certaines cellules de la colonne. Et pour la grosse case qui contient Non, ça ne calcul que la somme de la première ligne des cellules fusionnées (logique puisqu'elle est identifiée comme telle).
Tu saurais pas comment faire pour que toutes les cellules masquées du fait de la fusion ait la même valeur ?
Messages postés
1143
Date d'inscription
lundi 22 mars 2010
Statut
Membre
Dernière intervention
31 juillet 2019
102
Pour la méthode avec SOMME.SI c'est génial aussi : je vois pas vraiment la différence... :) C'est juste plus facile à comprendre.

Mais toujours le même problème : un Non qui est dans trois cellules fusionnés n'est compté que pour la première ligne de ces trois celulles (qui ne forment plus qu'une).
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
817
Re le Forum

Un fichier : Fusion.ods

Si c'est pas cela, essaye de joindre un fichier avec les résultats souhaités.

Pour joindre un fichier utilise https://www.cjoint.com/
et recopie le lien fourni dans ton prochain message.

Mytå
Messages postés
1143
Date d'inscription
lundi 22 mars 2010
Statut
Membre
Dernière intervention
31 juillet 2019
102
OK, merci !
En fait, je faisais la fusion avant de remplir la case, donc ce message n'apparaissait pas.
Je saurai maintenant. :)

Si tu as une alternative pour remplir les cellules cachées (quand on fait la fusion avant de remplir comme je le faisais) c'est pas de refus. ;)

Merci beaucoup en tout cas ! :)