Excel : bascule de date?

Résolu/Fermé
kilian66
Messages postés
87
Date d'inscription
jeudi 12 août 2010
Statut
Membre
Dernière intervention
5 septembre 2014
- 3 sept. 2014 à 23:31
kilian66
Messages postés
87
Date d'inscription
jeudi 12 août 2010
Statut
Membre
Dernière intervention
5 septembre 2014
- 5 sept. 2014 à 21:43
Bonjour,
J'ai besoin de créer une formule dans le cadre de mon travail sur des dates, dans cette logique :
- Imaginons un tableau de 2 colonnes : "date de traitement" et "deadline"
- la colone deadline serait déjà remplie avec des dates diverses de l'année

Ce que je cherche à faire :
- si (sur la même ligne) la date de "deadline" (G5) et supérieure ou égale au 20 du mois alors "date de traitement" (G4) affiche le mois suivant sinon il re-affiche la même date

Autrement dit en langage excel, l'idée c'est :
=SI(G5>(19/mois/année); (Mois de G5)+1; G5)

Merci pour votre aide

3 réponses

HiTech4ever
Messages postés
98
Date d'inscription
mardi 2 septembre 2014
Statut
Membre
Dernière intervention
18 décembre 2016
24
Modifié par HiTech4ever le 4/09/2014 à 01:36
un début de solution, deux formules :

MOIS.DECALER : Renvoie le numéro de série qui représente la date correspondant à une date spécifiée (l'argument date_départ), corrigée en plus ou en moins du nombre de mois indiqué. Utilisez la fonction MOIS.DECALER pour calculer des dates d'échéance ou de coupon tombant le même jour du mois que la date d'émission.

=AUJOURDHUI() : Renvoie le numéro de série de la date du jour. Le numéro de série est le code de date et d'heure utilisé par Microsoft Excel pour les calculs de date et d'heure. Si le format de la cellule était Standard avant que la fonction ne soit entrée, Excel modifie le format de la cellule en Date. Pour afficher le numéro de série, changez le format de la cellule en Standard ou Nombre.

Je pense que tu dois inséré une 3é colonne et y mettre la date du jour [=AUJOURDHUI()] pour te servir de base de comparaison..

Bon courage..c'est un vrai casse-tête chinois ;)
0
cbauf
Messages postés
4245
Date d'inscription
lundi 31 mars 2008
Statut
Contributeur
Dernière intervention
22 juin 2022
801
4 sept. 2014 à 04:37
Hi, un peut-être petit plus !

DATEDIF
0
pijaku
Messages postés
12259
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
9 août 2022
2 701
4 sept. 2014 à 11:40
Bonjour,

ça n'est pas de la programmation, mais une formule Excel.

Donc, en G4, saisir la formule :

=SI(JOUR(G5)>=20;DATE(ANNEE(G5);MOIS(G5)+1;JOUR(G5));G5)
0
kilian66
Messages postés
87
Date d'inscription
jeudi 12 août 2010
Statut
Membre
Dernière intervention
5 septembre 2014
22
5 sept. 2014 à 21:43
Merci Franck!
Rien à redire, ça marche du premier coup!

Merci 1000 fois!
0