Comment extraire un chiffre dans une cellule [Résolu/Fermé]

Signaler
-
 vazah -
Bonjour,

Est-ce possible d'extraire deux chiffres qui se situe à des positions différentes dans le texte.

Voici mes deux possibilités (les chiffres sont des exemples).

A1: XXXX_40.3ab...
A2: 35cd_...
A3: XXXX_ 56ab
etc....

Comment faire pour qu'une seule formule puisse me donner les deux premiers chiffres qu'il détecte.

Merci pour votre aide

3 réponses

Messages postés
25620
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 novembre 2020
5 626
Bonjour
si vous n'avez vraiment que ces deux configurations, c'est à dire:
__soit le texte commence par les deux chiffres
__soit le chiffre dans let texte est précédé par underscore
cette formule devrait faire l'affaire

=SI(ESTERREUR(GAUCHE(A2;1)*1);STXT(A2;TROUVE("_";A2;1)+1;2)*1;GAUCHE(A2;2)*1)

crdlmnt

Messages postés
12863
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
28 novembre 2020
2 072
Bonjour

Possible avec une fonction personnalisée

ALT F11 pour ouvrir l'éditeur VBA
Onglet Insertion Module

Copier et coller cette fonction :

Function chiffres(chaine)
chif = ""
For n = 1 To Len(chaine)
c = Mid(chaine, n, 1)
If c >= "0" And c <= "9" And Len(chif) < 2 Then chif = chif & c
Next
chiffres = Val(chif)
End Function

Fermer l'éditeur

S'utilise après comme n'importe quelle fonction
= chiffres (A1) renverra 40

Cdlmnt
Salut,

J'ai finalement trouvé la solution:

GAUCHE(C1;CHERCHE("Mb";C1)+1)

Merci
Messages postés
12863
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
28 novembre 2020
2 072
Rien à voir avec la demande de départ où il n'était pas question de Mb !!!
merci; c'est très interessant