Horaire sur open office calc [Résolu/Fermé]

Signaler
Messages postés
242
Date d'inscription
vendredi 14 février 2014
Statut
Membre
Dernière intervention
21 avril 2019
-
Messages postés
242
Date d'inscription
vendredi 14 février 2014
Statut
Membre
Dernière intervention
21 avril 2019
-
Bonjour,
Pourriez vous m'aidez s'il vous plait à résoudre ce problème très agaçant
Vous trouverez ci-joint un tableur qui illustre des heures de présence...
Les Colonnes A et B représentent des minutes déduites, par exemple si la personne passe 15 mn chez un client , 2 minutes seront déduites pour le déplacement etc...
Le problème se trouve dans la colonne J, ce que je voulais c'est que lorsque la Mention APA était précisée dans la colonne I, les minutes a décompter devraient s'inscrire dans la colonne J, mais voilà le hic , ca fonctionnait très bien pour tous les écarts , 30 mn , 45m 1h etc... Mais pour les 15 mn ca ne fonctionne pas toujours, ( voir les cellules en rouge)
Prenons un exemple , dans la ligne 10, cellule F10 nous inscrivons 13h au lieu de 18h et 13h15 au lieu de 18h15 en G10 et bien la J10 me mettera 00:00 minutes à supprimé , alors que ca me donnait 00:02 pour 18:00 et 18:15 !
Incroyable ca !
Ce sont exclusivement des écarts de 15mn qui ne fonctionnent pas , et particulièrement les écarts 13:00-13:15 16:00-16:15 19:00-19:15 , Toutes les trois heures !!
merci d'avance pour vos précisions, car je ne m'en sors pas
j'ai essayé de ramené en format nombre , c'est exactement le même problème.
Cordialement
Soubisien85
https://www.cjoint.com/?DIcafgxh0LJ

4 réponses

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
871
Salut le Forum

Il suffit de mettre tes cellules en nombres avec 15 décimales tu verras l'erreur.

Mytå
Messages postés
242
Date d'inscription
vendredi 14 février 2014
Statut
Membre
Dernière intervention
21 avril 2019
2
Non ca ne fonctionne pas , vous pouvez essayer...
Merci Quand même

Soubisien85
Messages postés
2485
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
24 juin 2021
1 136
Bonjour
Les valeurs calculées ne sont pas strictement égales (difficulté de la transformation de nombre complexes en décimale et binaire)

Une proposition de solution

1-Créer une plage de recherche :
En C15 ramener en texte avec la formule =CTXT(C2;3) et recopier jusqu'à C26
En D15 =D2 recopier jusqu'à D26

2 en L2
=SI(K2="APA";RECHERCHEV(CTXT(J2;3);$C$15:$D$26;2;0);"")
recopier jusqu'à L32

$C$15:$D$26 est la plage de recherche
2 colonne de résultat de recherche
0 indice de tri
Messages postés
242
Date d'inscription
vendredi 14 février 2014
Statut
Membre
Dernière intervention
21 avril 2019
2
Ce n'est pas ce que je voulais... en tout cas merci quand même, j'ai fini par trouver, avec la fonction =ARRONDI, et en recopiant les cellules , ca fonctionne impec !

Merci beaucoup quand même !
Cordialement

Soubisien