Proxy inversé Pound: Erreur SSL_CTX_use_certificate_chain_f... [Résolu/Fermé]

Signaler
-
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Bonjour,

Bien que j'ai pu chercher une réponse avec Google, je n'ai pas trouvé réponse à ma question.

En fait j'ai mon proxy inversé qui m'affiche une erreur lors du (re)démarrage du service.

En effet il m'affiche "/etc/pound/pound.cfg line 53: SSL_CTX_use_PrivateKey_file - aborted".

J'ai donc essayé de mettre uniquement le nom de fichier "server.crt" au lieu de l'adresse aboslue, mais rien n'y fait.

Merci d'avance ;-)


Voici mon fichier de config:




## Minimal sample pound.cfg
##
## see pound(8) for details


######################################################################
## global options:

User  "www-data"
Group  "www-data"
#RootJail "/chroot/pound"

## Logging: (goes to syslog by default)
## 0 no logging
## 1 normal
## 2 extended
## 3 Apache-style (common log format)
LogLevel 1

## check backend every X secs:
Alive  30

## use hardware-accelleration card supported by openssl(1):
#SSLEngine "OpenSSL-engine"

# poundctl control socket
Control "/var/run/pound/poundctl.socket"


######################################################################
## listen, redirect and ... to:

## redirect all requests on port 8080 ("ListenHTTP") to the local webserver (see "Service" below):
ListenHTTP
 Address 192.168.1.14
 Port 80

 ## allow PUT and DELETE also (by default only GET, POST and HEAD)?:
 xHTTP  0

 Service
  BackEnd
   Address 192.168.1.15
   Port 80
  End
 End
End


ListenHTTPS
 Address 192.168.1.14
 Port 443
 Cert "/etc/pound/server.crt"
 ## allow PUT and DELETE also (by default only GET, POST and HEAD)?:
 xHTTP  0

 Service
  BackEnd
   Address 192.168.1.15
   Port 443
  End
 End
End

2 réponses

Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
Bonjour,

Est-ce que cela a déjà fonctionné ou bien cela n'a jamais fonctionné ?

En faisant une recherche sur le net avec le message d'erreur, il y a pourtant beaucoup de réponses .... ^^


- le certificat devrait être au format pem
- soit il y a un problème d'ordre dans le certificat
- soit la clé privée est cryptée (et ne devrait pas)
- soit le certificat n'est pas bon !

Bon courage.

un penguin sur la banquise (qui rétrécit ! qui rétrécit !)

Re,

Merci effectivement le certificat auto-signé ne semble pas être valide (doc erronée) et il le fallait au format pem.

Maintenant reste à résoudre l'erreur 400, mdr ;-)

Gracias ;-)
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
469
No problémo

pour l'erreur 400, faire un nouveau post si toujours problème, j'essaierai de vous aider si possible.