Le son avec sfml

Résolu/Fermé
lodykas Messages postés 30 Date d'inscription vendredi 25 avril 2014 Statut Membre Dernière intervention 29 novembre 2014 - 8 août 2014 à 12:51
lodykas Messages postés 30 Date d'inscription vendredi 25 avril 2014 Statut Membre Dernière intervention 29 novembre 2014 - 29 nov. 2014 à 01:02
bonjour à tous!
alors, voilà mon souci: j'apprends à utiliser la bibliothèque sfml, et malgré tout mes efforts, impossible de jouer le moindre son. je n'ai pourtant pas d'erreur de compilation (j'utilise MinGW), le fichier est bien lu par le programme, et ni mon pc, ni le programme n'est muet.
le fichier en lui-même est lut par windows media player, donc le problème ne vient pas de là.

Merci d'avance à ceux qui m'aideront!

2 réponses

schancel Messages postés 296 Date d'inscription dimanche 20 mars 2011 Statut Membre Dernière intervention 7 décembre 2018 49
9 août 2014 à 13:34
Salut
serait-il possible d'avoir ton code ?
0
lodykas Messages postés 30 Date d'inscription vendredi 25 avril 2014 Statut Membre Dernière intervention 29 novembre 2014 11
11 août 2014 à 14:42
Merci à toi d'avoir répondu!
Mon code est un copier-coller du tutoriel officiel de la sfml, il ne devrait pas y avoir de souci.
mais après de plus amples tests, le plroblèmeviendrait du fichier .wav! en effet, avec d'autres sons (trouvés dans C/windows/media) cela fonctionnait! par contre, je n'ai aucun indice sur le pourquoi...
la taille du fichier peut-elle être la source du problème?
0
lodykas Messages postés 30 Date d'inscription vendredi 25 avril 2014 Statut Membre Dernière intervention 29 novembre 2014 11
29 nov. 2014 à 01:02
bon, et bien apres avoir changé de format, ca a fonctionné.
0