Comment calculer l'âge au 6 mois le plus proche sous excel 2007 [Résolu/Fermé]

Signaler
Messages postés
35
Date d'inscription
mardi 1 juillet 2014
Statut
Membre
Dernière intervention
29 février 2016
-
Messages postés
35
Date d'inscription
mardi 1 juillet 2014
Statut
Membre
Dernière intervention
29 février 2016
-
Bonjour,

J'utilise déjà une formule qui me permet de trouver l'âge d'une personne. Par contre, je voudrais également trouver l'âge au 6 mois le plus proche.

Hypothèse: aujourd'hui 1 juillet 2014
Date de naissance: 15 mai 1982

Formule normale que j'utilise: =SI(MOIS(AUJOURDHUI())>MOIS(B1);ANNEE(AUJOURDHUI())-ANNEE(B1);SI(MOIS(AUJOURDHUI())<MOIS(B1);ANNEE(AUJOURDHUI())-ANNEE(B1)-1;SI(JOUR(AUJOURDHUI())<JOUR(B1);ANNEE(AUJOURDHUI())-ANNEE(B1)-1;ANNEE(AUJOURDHUI())-ANNEE(B1))))

Résultat = 32 ans

Maintenant ce que je voudrais avoir comme résultat est 33 ans aussitôt que la personne est rendu a 32 ans 6 mois et un jour!

Merci de votre aide.

4 réponses

Messages postés
2368
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
8 octobre 2020
879
Bonjour,
Pourquoi pas avec Datedif:
https://www.commentcamarche.net/faq/22460-difference-entre-dates-avec-la-fonction-datedif

=DATEDIF(A1;A2;"y")+SI(DATEDIF(A1;A2;"ym")>=6;1;0)
ou
=DATEDIF(A1;A2;"y")+(DATEDIF(A1;A2;"ym")>=6)*1
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
35
Date d'inscription
mardi 1 juillet 2014
Statut
Membre
Dernière intervention
29 février 2016
2
Je ne sais pas s'il y a vraiment une différence entre les deux formules en bout de ligne mais après les avoir essayées, les deux fonctionne très bien dans mon système merci beaucoup!
Messages postés
17245
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 octobre 2020
4 286
Bonsoir,

regarde si cela correspond à tes attentes

=SI(DROITE((DATEDIF(B1;AUJOURDHUI();"y")&","&DATEDIF(B1;AUJOURDHUI();"ym"))*1;1)*1=6;TRONQUE((DATEDIF(B1;AUJOURDHUI();"y")&","&DATEDIF(B1;AUJOURDHUI();"ym"))*1)+1;TRONQUE((DATEDIF(B1;AUJOURDHUI();"y")&","&DATEDIF(B1;AUJOURDHUI();"ym"))*1))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
35
Date d'inscription
mardi 1 juillet 2014
Statut
Membre
Dernière intervention
29 février 2016
2
Bonsoir Mike-31,

Ta formule marche nickel, elle est juste plus longue que Tontong. Merci pour votre aide! c'est ma première fois sur un forum et je m'attendais pas a avoir des réponses si rapidement merci encore!
Messages postés
12760
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 octobre 2020
2 041
Bonsoir

Plus simplement pour avoir l'age en années :
=DATEDIF(B1;AUJOURDHUI();"y")

Et pour l'avoir en années et en mois :
=DATEDIF(B1;AUJOURDHUI();"y") & " ans et " & MOD(DATEDIF(B1;AUJOURDHUI();"m");12) & " mois"

Et pour arrondir à l'age supérieur au bout de 6 mois
=DATEDIF(B1;MOIS.DECALER(AUJOURDHUI();6);"y")

Cdlmnt

"L'imagination est plus importante que le savoir." A. Einstein
Messages postés
35
Date d'inscription
mardi 1 juillet 2014
Statut
Membre
Dernière intervention
29 février 2016
2
Effectivement Via55 la demande avait pour objet de retourner un âge ajuster à la hausse aussi tôt que la personne atteind 6 mois durant l'année. Merci!
Messages postés
5518
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
7 octobre 2020
497
Bonjour

Comme vôtre précision est de 6 mois on peut utiliser une formule comme celle-ci

=SI((AUJOURDHUI()-B1)/365,25-ENT((AUJOURDHUI()-B1)/365,25)>0,5;(AUJOURDHUI()-B1)/365,25+0,5;(AUJOURDHUI()-B1)/365,25)

j'espère que cela vous aidera
Messages postés
35
Date d'inscription
mardi 1 juillet 2014
Statut
Membre
Dernière intervention
29 février 2016
2
Bonjour Philou10120,

La formule ne retourne pas l'âge arrondi on est pas loin mais le resultat n'est pas celui que je voulais obtenir par contre tontong à fournis une réponse qui fait bien le travail. Merci à tous!!