Wordpress admin inaccessible sous Trisquel (Ubuntu) ?... :(

Fermé
Signaler
Messages postés
9
Date d'inscription
dimanche 29 mars 2009
Statut
Membre
Dernière intervention
11 mai 2014
-
Messages postés
9
Date d'inscription
dimanche 29 mars 2009
Statut
Membre
Dernière intervention
11 mai 2014
-
Bonjour,

Je suis sous la distrib. Trisquel basée sur Ubuntu, un informaticien m'a installé un Wordpress en local host en rentrant des codes (sans passer par LAMP à priori) il n'est en tout cas pas installé. Depuis que j'ai essayé de changer le mot de passe (maladroitement) je n'ai plus accès à l'admin de wordpress. Quand je tape localhost dans le moteur de recherche j'ai bien "it works". Avant cette erreur de manip. tout fonctionnait nickel. j'avais accès au site en tapant localhost/wordpress/wp-admin (dans lequel ai changé mot de passe),
Je n'ai maintenant accès qu'à phpmyadmin où j'ai essayé de rentrer le nouveau MDP en effectuant la manip suivante :

clic sur wordpress à gauche, à droite une ligne, je coche et choisis "éditer en place", dans le gros rectangle user pass qui apparaît en chiffres et lettres codés je tape mon MDP normal genre bibifricotain9, ensuite je clique sur modifier là dans la case user pass je retape le même MDP, menu déroulant je choisis "MD5" et tout en bas sauvegarder et ensuite retourner à la page précédente. Ca ne fonctionne toujours pas..

Dans phpMyAdmin, il y a 4 menus :

information_schema
mysql
performance_schema
wordpress

Dans wordpress on trouve une table wp user (avec une seule ligne pour l'admin.) user login = mumu et dans mysql une table user avec 5 lignes (rubrique Host : localhost - mumu-hp-530-notebook-pc - 127.0.0.1 et ::1 et rubrique user = root (je précise que lorsque tout fonctionnait les nom utilisateur étaient déjà différents (dans localhost/wordpress/wp-admin pour écriture du site util = mumu et passe manche50 qui seul a été changé vu que pas possible de toute façon de changer l'utilisateur) et dans phpmyadmin util était root avec le même mot de passe, changé (le même que pour l'admin WP).

Dans WP y'a plusieurs noms d'utilisateur après user_login et user_pass : user_nicename user_activation_key display_name (que j'ai changé aussi et qui est bien présent en clair).

Précisions peut-être utiles : phpadmin dans le menu localhost / paramètres d'affichages / clic sur plus de paramètres = rubrique importer j'ai message "vous n'avez pas sauvegardé les paramètres" ??? puis de là si clic sur "fenêtre plus de paramètres, vous pouvez régler d'autres paramètres en modifiant config.inc.php, par exemple au moyen du script d'installation. Documentation" clic sur script d'installation = Survol : Impossible de charger ou sauvegarder la configuration Veuillez créer le répertoire config accessible en écriture tel que décrit dans la documentation. Sinon vous ne pourrez que télécharger ou afficher la configuration.

Sauf que n'ayant pas WAMP je ne sais pas comment faire et si c'est nécessaire de le faire vu que ça fonctionnait TB avant sans ?! Il s'agirait d'ouvrir un dossier config in the phpMyAdmin directory... Je trouve aussi dans localhost / wordpress, onglet opérations tout en bas ceci : Le stockage de configurations phpMyAdmin a été désactivé. Pour une analyse du problème, cliquez ici. Lorsque je clique j'ai ces messages d'erreurs :

Je pense que certains messages d'erreur sont liés au fait que je suis pour le moment en local me manquerait juste la manip pour que la modif du mot de passe soit prise en compte ?


$cfg['Servers'][$i]['pmadb'] ... en erreur [ Documentation ]
$cfg['Servers'][$i]['relation'] ... en erreur [ Documentation ]
Fonctions relationnelles: Désactivé

$cfg['Servers'][$i]['table_info'] ... en erreur [ Documentation ]
Affichage infobulle: Désactivé

$cfg['Servers'][$i]['table_coords'] ... en erreur [ Documentation ]
$cfg['Servers'][$i]['pdf_pages'] ... en erreur [ Documentation ]
Génération de schémas en PDF: Désactivé

$cfg['Servers'][$i]['column_info'] ... en erreur [ Documentation ]
Commentaires de colonnes: Désactivé
Transformation: Désactivé

$cfg['Servers'][$i]['bookmarktable'] ... en erreur [ Documentation ]
Requêtes SQL en signets: Désactivé

$cfg['Servers'][$i]['history'] ... en erreur [ Documentation ]
Historique SQL: Désactivé

$cfg['Servers'][$i]['designer_coords'] ... en erreur [ Documentation ]
Concepteur: Désactivé

$cfg['Servers'][$i]['tracking'] ... en erreur [ Documentation ]
Suivi: Désactivé

$cfg['Servers'][$i]['userconfig'] ... en erreur [ Documentation ]
Préférences de l'utilisateur: Désactivé

Guide rapide de configuration des fonctions avancées :

Créez les tables requises au moyen de script/create_tables.sql. Documentation
Créez un utilisateur pma et donnez-lui accès à ces tables. Documentation
Activez les fonctions avancées dans le fichier de configuration (config.inc.php), en vous basant par exemple sur config.sample.inc.php. Documentation
Reconnectez-vous à phpMyAdmin afin d'utiliser le fichier de configuration modifié.

Merci d'avoir lu en espérant que quelqu'un pourra m'aider à résoudre ce problème...

Bonne soirée.

2 réponses

Messages postés
9
Date d'inscription
dimanche 29 mars 2009
Statut
Membre
Dernière intervention
11 mai 2014

P.S. : J'ai oublié d'indiquer la config. de mon ordi. portable double boot XP / GNU Linux

Serveur: Localhost via UNIX socket
Version du serveur: 5.5.37-0ubuntu0.12.04.1
Version du protocole: 10
Utilisateur: root@localhost
Jeu de caractères pour MySQL: UTF-8 Unicode (utf8)
Apache/2.2.22 (Trisquel_GNU/Linux)
Version du client MySQL: 5.5.37
Extension PHP: mysqli Documentation
- Version de WordPress : 3.9

- Version de PHP/MySQL :
Version: 3.4.10.1deb1
Messages postés
9
Date d'inscription
dimanche 29 mars 2009
Statut
Membre
Dernière intervention
11 mai 2014

Re P.S. :

Après vérification, les paquets LAMP sont bien installés, ceux là (désolée) !!

Le paquet apache2 installe le serveur Apache 2.
Le paquet php5 installe le langage PHP 5
Le paquet libapache2-mod-php5 (module d'intégration dans Apache) est installé automatiquement 3).
Le paquet mysql-server installe le serveur MySQL.
Le paquet php5-mysql installe le module d'interface avec PHP. 4).