Excel- Nombre d'argument Si trop important. Besoin d'aide. [Résolu/Fermé]

Signaler
-
Messages postés
24141
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
-
Bonjour,

Je travail actuelement sur Excel 2013.

J'ai une formule a réalisé prenant compte un nombre trop important de Si.

Voila la formule:
=SI(U12=1;SI(U1=1;P12-K35;SI(U2=1;SI(N35<>"";P12-N35;P12-K35);SI(U3=1;SI(Q35<>"";P12-Q35;SI(N35<>"";P12-N35;P12-K35));SI(U4=1;SI(T35<>"";P12-T35;SI(Q35<>"";P12-Q35;SI(N35<>"";P12-N35;P12-K35)));"");"");"");"");"")

Donc en fonction de la valeur U12 ( point de départ, nous allons prendre en compte la valeur de U1,u2,u3 et u4.
En fonction de ces valeurs, il me faut parcourir un tableau et rechercher la valeur la plus a gauche possible pour la soustraire de moin point de départ ( p12).

J'ai beau réfléchir aux fonction recherchev, sommeprod ou autre , je ne trouve pas de solution.

Help pls ;)

Merci d'avance

4 réponses

Messages postés
16491
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 juillet 2021
3 200
Bonjour,

peut-^tre plus facile (voir plutôt que lire) en joignant la feuille en question

pour joindre une pièce
mettre le classeur sans données confidentielles en pièce jointe sur
http://cjoint.com/
puis copier l'adresse du lien et la coller dans le message de réponse

Je ne peux malheureusement pas joindre ce fichier ( dossier de travail confidentiel, étant stagiaire je ne prendrai aucuns risques :/ )

Si ma formule reste trop obscure, je pourrais éventuellement essayer de rapidement reproduire un tableau vierge.

Merci pour cette réponse si rapide dans tous les cas.

Dans l'attente de nouvelles réactions :)
Messages postés
24141
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
6 847
Bonjour à tous,

nouvelle réaction : dans l'attente d'un fichier anonymisé...
Voilà, c'est fait.

eric
Rebonjour.

Après moultes essais tarabiscoté, j'ai réussi à solutioner mon problème.

Je vous remercie d'avoir prit le temps de me lire ;)

Bonne journée !
Bonjour, ça fais deux jours que je cherche la solution a mon problème mais sans réponse. Je suis en train de créer une base de donner afin d'optimiser l'impression de fiche de débit, cependant, alors que tout mes tableaux fonctionnent, une formule me donne du fil a retordre, Excel m'avertis que j'ai taper trop d'argument pour cette fonction;
La voila :

=SI(D13="";"";SI(E4=Q4;J13+22;SI(E4=Q5;(J13+22-(D16-63))/2;SI(E4=Q6;SI(H4=U15;((J13+22)-(D16-63)-(B16-63))/3;(((J13+11)-(D16-63)-(B16-(W15*2+11))-(D12-W15)*4))/3)+(D12-W15)*2);SI(E4=Q7;SI(H4=U15;((J13+22)-(D16-63)-((B16-63)*2))/4;(((J13)-(D16-63)-((B16-(W15*2+11))*2)-((D12-W15)*4))/4)+((D12-W15)*2));SI(E4=Q8;J13+22;SI(E4=Q9;(J13+22-(D16-63))/2;SI(E4=Q10;J13+22 ;SI(E4=Q11;0;SI(E4=Q12;0;SI(E4=Q13;0;))))))))))

J'ai essayer de la réduire comme ceci:

=SI(D13="";"";SI(E4=Q4;ET(E4=Q8;ET(E4=Q10;J13+22)));SI(E4=Q5;ET(E4=Q9;(J13+22-(D16-63))/2;SI(E4=Q6;SI(H4=U15;((J13+22)-(D16-63)-(B16-63))/3;(((J13+11)-(D16-63)-(B16-(W15*2+11))-(D12-W15)*4))/3)+D12-W15)*2);SI(E4=Q7;SI(H4=U15;((J13+22)-(D16-63)-((B16-63)*2))/4;(((J13)-(D16-63)-((B16-(W15*2+11))*2)-((D12-W15)*4))/4)+((D12-W15)*2));SI(E4=Q11 ;ET(E4=Q12 ;ET(E4=Q13;0;))))

mais sans succès... Toujours le même message.
Messages postés
24141
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
6 847
Bonjour,

démarre ta propre question.
eric