Recherchev date - résultat case vide = 1900/01/00

[Fermé]
Signaler
Messages postés
4
Date d'inscription
mercredi 23 avril 2014
Statut
Membre
Dernière intervention
29 juin 2016
-
Messages postés
54877
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
-
Bonjour,

Dans un fichier Excel, j'ai 2 onglets (A et B). Lorsque dans l'onglet B je fais la recherche pour trouver les éléments qui sont dans A, j'obtiens des dates 1900/01/00 comme résultat pour des cellules vides de A.

Que dois-je ajouter dans ma formule pour éviter ce résultat ?

J'aurais aimé joindre un exemple du tableau en question mais je ne sais pas comment joindre un fichier à ce message.

Merci.

5 réponses

Messages postés
180
Date d'inscription
jeudi 12 juin 2008
Statut
Membre
Dernière intervention
16 octobre 2020
7
Sur excel allez dans Option Excel - Option Avancées - Section Afficher les options pour cette feuille de calcul - Décocher Afficher un zéro dans les cellules qui ont une valeur nulle.

;)
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
1943
Date d'inscription
lundi 16 août 2010
Statut
Contributeur
Dernière intervention
22 septembre 2021
61
Manon4046, Bonsoir.

Enregistrez votre feuille de calcul Excel sur le site gratuitement, www.cjoint.com, et de placer le lien ici pour le télécharger.

Je suis sûr que beaucoup de gens vont vous aider.
Je ne peux pas enregistrer mon fichier sur www.cjoint.com car mon employeur a mis un filtre qui n'accepte pas ce site.

En bref, mon fichier est conçu comme ceci :

Onglet A
# empl. Date 1
1 2012/01/02
2
3 2013/02/06

Onglet B
# empl. Date 1
1 =SI(ESTERREUR(RECHERCHEV(A1;'Onblet A'!$A$1:$B$260;2;FAUX));"";RECHERCHEV(A1;'Onglet A'!$A$1:$B$260;2;FAUX))
2 Je copie la formule
3

Donc, pour lel résultat de ma recherche, je ne veux pas de #N/A ni de 0.

Merci.
Messages postés
24201
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 octobre 2021
6 936
Bonsoir,

01/01/1900 = 1, début des dates pour excel.
00/01/1900 (=31/12/1899) est la valeur 0 si tu la mets au format date. Remet en format Standard si tu veux voir 0.

eric
Merci Éric. Ça fonctionne mais j'ai un résultat 0 que je ne veux pas. Je mets mon fichier exemple en pièce jointe tel que suggéré par Mazzaropi.
Messages postés
5701
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
20 octobre 2021
666
Bonjour

Ajouter un contrôle pour détecter une cellule vide

C7=""

et un 2 ème. si la rechercheV n'abouti pas

ESTERREUR(RECHERCHEV($C7;'feuil1'!$C$2:$S$100;3;FAUX));

dans cet exemple on affiche zéro si c'est faux. on peut mettre "" à la place si la cellule n'est pas utilisée pour des calculs

-=SI(OU($C7="";ESTERREUR(RECHERCHEV($C7;'feuil1'!$C$2:$S$100;3;FAUX)));0;RECHERCHEV($C7;'feuil1'!$C$2:$S$100;3;FAUX))

C'est en forgeant que l'on devient forgeron. - C'est au pied du mur que l'on voit le maçon - on apprend toujours de ses erreurs
Merci Philou10120. J'ai essayé ta formule mais j'obtiens aussi le résultat 0. Je joins mon fichier exemple, tel que suggéré par Mazzaropi.
Messages postés
54877
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
16 775
Manon, Manon !
Tu le répètes à deux reprises, mais tu ne le fais pas :
où est ce fameux fichier joint ?