Créer message en fonction d'une combinaison de lettres

Résolu/Fermé
Signaler
Messages postés
2
Date d'inscription
vendredi 18 avril 2014
Statut
Membre
Dernière intervention
18 avril 2014
-
Messages postés
2
Date d'inscription
vendredi 18 avril 2014
Statut
Membre
Dernière intervention
18 avril 2014
-
Bonjour,

Je souhaiterais savoir comment, dans une cellule, je pourrais créer une condition et avoir un message d'erreur en fonction des combinaisons de lettres dans les cellules d'une plage. Je m'explique :

J'ai une plage de cellules A2:E2.
En F2, j'aimerais qu'il y ait un message d'erreur si, dans les cellules de ma plage, je n'ai pas la combinaison A et C, ou A et D, ou B et D.
Donc, si dans ma plage j'ai seulement la lettre C et D, par exemple, je veux qu'il y ait un message d'erreur car cela ne concorde pas avec les combinaisons que j'ai préalablement validées.

Pour être 100% clair avec vous, j'accepte qu'il y ait AU MOINS une des combinaisons suivantes dans ma plage de 5 cellules (certaines peuvent rester vides) :
A et C
B et C
A et D
A et F
B et F

Si je ne remplis pas ces conditions, c'est à dire si dans toute ma plage de cellules j'ai par exemple:
A2 : C
B2 : F
C2 : vide
D2 : vide
E2 : F

et bien là j'aimerais un message d'erreur dans la cellule.

Voilà, j'espère que j'ai été clair, car pas évident de retranscrire ce que j'aimerais faire. Merci d'avance pour votre aide précieuse!

2 réponses

Messages postés
13200
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 novembre 2021
2 288
Bonjour

Essaie ceci :
=SI(ET(NB.SI(A2:E2;"A")=0;NB.SI(A2:E2;"B")=0);"erreur";SI(ET(NB.SI(A2:E2;"A")>0;OU(NB.SI(A2:E2;"C")>0;NB.SI(A2:E2;"D")>0;NB.SI(A2:E2;"F")>0));"";SI(ET(NB.SI(A2:E2;"B")>0;OU(NB.SI(A2:E2;"C")>0;NB.SI(A2:E2;"F")>0));"";"erreur")))


Cdlmnt
Messages postés
2
Date d'inscription
vendredi 18 avril 2014
Statut
Membre
Dernière intervention
18 avril 2014

Alors là, je suis bluffé! Chapeau bas via55 !
Je pensais sincèrement qu'il y aurait pu avoir une formule particulière pour cela, quelque chose de moins complexe :)

En tout cas merci beaucoup car cela fonctionne à merveille!

Bien à toi,