Mise en forme condition pour un texte

[Fermé]
Signaler
-
Messages postés
13116
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 octobre 2021
-
Bonjour,

Voilà je désespère car je ne trouve pas la mise en condition pour le problème suivant :

J'ai un texte qui apparaît selon les conditions suivantes : si(ou(et(cellule A vide; cellule B vide);et(cellule A remplie; cellule B remplie);"texte"

Je voudrais que le texte n'apparaisse pas si cellule C ou cellule D sont remplies

1 réponse

Messages postés
13116
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 octobre 2021
2 263
Bonsoir

Si j'ai bien compris le problème :

=Si (ou(cellule C remplie; cellule D remplie);"";la suite avec ta formule si déjà existante , ce qui donnerait par exemple :

=SI(OU(C1<>"";D1<>"");"";SI(OU(ET(A1="";B1="");ET(A1<>"";B1<>""));"texte";""))

J'ai rajouté;"" à la fin qui n'était pas dans ta formule pour que rien n'apparaisse au lieu de FAUX si un seul de A ou B est rempli

Cdlmnt
Voilà ma formule qui affiche le texte ; =SI(OU(ET(Y30="";Y32="");ET(Y30<>"";Y32<>""));"Veuillez mettre une X dans une des 2 cases";"")

Je veux que cette phrase n'apparaisse pas si Y10="x" et/ou Y20="x"
Messages postés
13116
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 octobre 2021
2 263
Il suffisait d'adapter ma formule :

=SI(OU(Y10="x";Y20="x");"";SI(OU(ET(Y30="";Y32="");ET(Y30<>"";Y32<>""));"Veuillez mettre une X dans une des 2 cases";""))

Cdlmnt