Formule combinée stxt

[Résolu/Fermé]
Signaler
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019
-
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019
-
Bonjour,

J'utilise la formule ci dessous
=STXT(D77;20;TROUVE("-";D77;1)-20)

afin d'extraire les chiffres 140400132988 de la ligne suivante:
PRLV SEPA aaa bbb 140400132988-860003506417 860003506417 Z

j'aimerai rajouter une autre requête par rapport à la ligne:
VIR Dbbb - AAA SCT BEE/CCC-P 00000123456789 9852 300000534746 DAaa DU JUSTIFICATIF:2014-02-10 / 985205

je voulais savoir si je pouvais combiner les 2 requêtes et mettre une condition selon la ligne qui apparait ?

Merci d'avance pr votre réponse

9 réponses

Messages postés
5622
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 septembre 2021
645
Bonjour

La formule pour texte en B3

=SI(ET(GAUCHE(B3;3)="VIR";NBCAR(B3)<=45);DROITE(B3;12);SI(ET(GAUCHE(B3;4)="PRLV";NBCAR(B3)=59);GAUCHE(DROITE(B3;40);12);SI(ET(GAUCHE(B3;3)="VIR";NBCAR(B3)=102);GAUCHE(DROITE(B3;53);12))))

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
938
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
54
Donen nous un exemple pour ce que tu cherches, enfin ce que tu as, et ce que tu aimerais
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

l'ai les deux lignes ci dessous qui s'affiche selon les opération

PRLV SEPA ABC DEFG 300001173232-840003433374 840003433374 Z
VIR BEF - AAAAA BBB ET CCCCC 00000124892384 9852 300000057809 DATE DU JUSTIFICATIF:2012-02-27 / 985205

et j'aimerai avoir une formule qui m'extrait les 300001173232 ou les 300000057809 selon le cas

auparavant j'avais toujours des lignes avec les memes caracteres donc j'utilisais la formule =STXT(D77;20;TROUVE("-";D77;1)-20) pour extraire mes chiffres mais maintenant j'ai une deuxième ligne donc le traitement est plus long puisque je fais a la main.

merci d'avance
Messages postés
938
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
54
c'est deux lignes excel ? ou deux lignes dans une cellule ?

Et pourquoi tu utilisent pas tout simplement un formule avec Si() ?
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

oui deux lignes excel;
c'etait ma question et c'est parce que je voulais avoir de l'aide pr le faire :)
Messages postés
938
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
54
C'est quoi la condition qui détermine si excel doit choisir l'un ou l'autre chiffre ?
Messages postés
938
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
54
=si(*Condition*;STXT(D77;20;TROUVE("-";D77;1)-20);STXT(D78;20;TROUVE(" DATE";D78;1)-20)
Messages postés
938
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
54
=si(stxt(D77;18;1)="PRLV SEPA ABC DEFG";STXT(D77;20;TROUVE("-";D77;1)-20);STXT(D78;20;TROUVE(" DATE";D78;1)-20)
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

et si jamais il y a une troisième condition il y a encore possibilité de rajouter une troisieme?
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

il ne prend pas la premiere condition le resultat m'affiche VALEUR
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

ca va etre :
commencant par :"PRLV SEPA ABC DEFG" pr le STXT(D77;20;TROUVE("-";D77;1)-20)
et l'autre: "VIR BEF - AAAAA BBB ET CCCCC" pr l'autre
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

Bonjour,

Je remercie skk201 pr son aide mais la condition ne marche pas.
c'est à dire qu'il m'affiche #VALEUR!; j'ai l'impression qu'il n'aime pas le si(stxt(D77;18;1)="PRLV SEPA ABC DEFG"; de la formule =si(stxt(D77;18;1)="PRLV SEPA ABC DEFG";STXT(D77;20;TROUVE("-";D77;1)-20);STXT(D78;20;TROUVE(" DATE";D78;1)-20)

Merci d'avance pr votre aide
Messages postés
938
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
54
c'est plutot bizzard la formule semble juste, je vai l'essayer chez moi après.

Est-ce que tu aurais un classeur exemple ?
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

tu peux me dire comment je peux te l'envoyer?
Messages postés
938
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
54
cjoint.com
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

bonjour,

ci joint un exemple:
https://www.cjoint.com/?3CpnQBmFkWS
je t'ai mis les 3 cas que j'ai actuellement par contre la colonne F est en valeur.

merci d'avance pr ton aide
Messages postés
5622
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 septembre 2021
645
Bonjour

Une formule

=SI(GAUCHE(C7;3)="VIR";GAUCHE(DROITE(C7;53);12);GAUCHE(DROITE(C7;40);12))

C7 la cellule contenant la ligne à traiter
Les lignes sont standardisées et doivent toujours se présenter de la même manière.
c'est certainement le cas en Banque
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

et oui bingo pr la banque
par contre je comprends la formule GAUCHE(DROITE(C7;53);12; c'est il compte les 53 caractères à partir de la droite et il sélectionne les 12 caractères c'est bien ça?
Et par exemple on peut mettre une 3eme critère? (cf.fichier joint au dessus)

Merci d'avance
Messages postés
60
Date d'inscription
mercredi 27 février 2013
Statut
Membre
Dernière intervention
20 juin 2019

MERCI :)