Trouver des doublons

Résolu/Fermé
Signaler
Messages postés
36
Date d'inscription
jeudi 19 décembre 2013
Statut
Membre
Dernière intervention
27 février 2014
-
Messages postés
17815
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 janvier 2022
-
EXCEL 2000

Bonjour

Dans une feuille excel, j'ai deux colonnes de données cote à cote. (environ 800 cellules chacune)
Je souhaiterai supprimer les cellules de la seconde colonne si les données se trouvent déjà dans la première colonne. (être sûr que les données de la seconde colonne ne sont pas déjà dans la première)
Comment faire au plus simple ?
Merci

12 réponses

Messages postés
17815
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 janvier 2022
4 913
Bonjour,

Utilise la mise en forme conditionnelle, en supposant que tes données sont en colonne A et B et tu souhaites repérer les doublons de la colonne B.
mettre la plage de la colonne B en surbrillance, mise en forme conditionnelle, la formule est

=NB.SI($A$1:$A$20;$B1)>0
Format choisir une couleur de remplissage
les données de la colonne B qui seront en doublon par rapport à la colonne A se coloriseront, ensuite tu les traite comme tu veux

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
Messages postés
36
Date d'inscription
jeudi 19 décembre 2013
Statut
Membre
Dernière intervention
27 février 2014

bonsoir Mike

Ouverture de mon fichier.
(juste ma feuille1 et rien sur les autres)
j'ai sélectionné ma colonne B
forme conditionnelle
la formule est : =NB.SI($A$1:$A$20;$B1)>0
format (couleur jaune)
OK
Et rien ne se passe ?
0
Messages postés
17815
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 janvier 2022
4 913
Re,

vite fait un exemple de recherche de doublons dans la colonne B et E par rapport à la colonne A


https://www.cjoint.com/c/DBBscGbattz
0
Messages postés
36
Date d'inscription
jeudi 19 décembre 2013
Statut
Membre
Dernière intervention
27 février 2014

???? Je suis sur excel 2000 ?
0
Messages postés
17815
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 janvier 2022
4 913
Re,

Ah excuse c'est vrai, voila l'exemple

https://www.cjoint.com/?DBBsAhFHdZS


tu devrais télécharger le pack de compatibilité gratuitement sur ce lien

https://www.commentcamarche.net/download/s/

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
Messages postés
36
Date d'inscription
jeudi 19 décembre 2013
Statut
Membre
Dernière intervention
27 février 2014

Ca fonctionne, j'ai changé la couleur.......
Mais, dans ton exemple que fais la colonne E ?
Je n'ai que mes 2 colonnes, moi ??????
0
Messages postés
17815
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 janvier 2022
4 913
Re,

Rien simplement pour te montrer qu'il est possible de comparer plusieurs colonnes
Cordialement
0
Messages postés
36
Date d'inscription
jeudi 19 décembre 2013
Statut
Membre
Dernière intervention
27 février 2014

pourquoi ça ne fonctionne pas sur mon fichier alors Mike ?
0
Messages postés
17815
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 janvier 2022
4 913
Re,

tu as traité la colonne B avec cette formule

=NB.SI($A$1:$A$20;$B1)>0

si tu veux traiter également la colonne E il faut recommencer par sélectionner la colonne E et dans la mise en forme conditionnelle saisir la formule adaptée toujours par rapport à la colonne A

=NB.SI($A$1:$A$20;$E1)>0
0
Messages postés
36
Date d'inscription
jeudi 19 décembre 2013
Statut
Membre
Dernière intervention
27 février 2014

je repose ma question:
pourquoi ça ne fonctionne pas sur mon propre fichier alors Mike ?
0
Messages postés
17815
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
17 janvier 2022
4 913
RE,

je reviens, si par exemple tu veux comparer la plage de la colonne A2 à A100 à la colonne B et donc coloriser les doublons rencontré en colonne B

mettre la plage B2 à B100 en surbrillance, ouvrir l'assistant de Mise en forme conditionnelle, la formule sera =NB.SI($A$2:$A$100;$B2)>0 et tu choisis un format de colorisation

si tu veux coloriser les doublons de la colonne X par rapport toujours à la plage A2:A100, mettre en surbrillance la plage X2:X100, mise en forme conditionnelle
la formule sera

=NB.SI($A$2:$A$100;$X2)>0 et format/remplissage, sélection de la couleur

voilà ce n'est pas plus compliqué
0
Bonjour,

Dans un premier temp, copie ta seconde colonne dans une autre feuille
en colone B tu effectue une RECHERCHEV sur la première colonne de ta feuille une.

s'il t'intique une valeur c'est que c'est un doublon, s'il t'indique #N/A la valeur est unique.

Tu n'as plus qu'à appliquer un filtre et décocher les #N/A et suupprimer les lignes qui sont filtrer et le tour est joué.
-1
Messages postés
36
Date d'inscription
jeudi 19 décembre 2013
Statut
Membre
Dernière intervention
27 février 2014

Oui mais non, Weapon...
Ce que tu me propose ne change pas directement la couleur des liens dans ma colonne B ?
et c'est ce que je cherche, une modif directe sur ma colonne contenant les doublons.....
0