Comparer 2 listes excel

Résolu/Fermé
yo-72 Messages postés 3 Date d'inscription jeudi 20 février 2014 Statut Membre Dernière intervention 20 février 2014 - 20 févr. 2014 à 09:39
yo-72 Messages postés 3 Date d'inscription jeudi 20 février 2014 Statut Membre Dernière intervention 20 février 2014 - 20 févr. 2014 à 15:45
bonjour,

Je voudrais comparer 2 listes identiques dans la forme.
je voudrait que les références identiques comparent les quantités en stock.
ex : pour une référence 123456, quantité 100 dans la feuille 1 et Quantité 75 dans la feuille 2, que l'on me dise qu'il m'en reste 25.

le problème c'est qu'il y a pas le même nombre de références dans les deux listes

Merci.

3 réponses

yo-72 Messages postés 3 Date d'inscription jeudi 20 février 2014 Statut Membre Dernière intervention 20 février 2014 1
20 févr. 2014 à 10:12
voici le lien :

https://www.cjoint.com/?0BukkYkfr9Y

Merci.
1
eriiic Messages postés 24463 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 23 novembre 2022 7 141
20 févr. 2014 à 09:53
Bonjour,

Tu devrais déposer un fichier de travail avec qcq lignes sur cjoint.com, et coller ici le lien fourni.

eric
0
Le Pingou Messages postés 11303 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 25 novembre 2022 1 314
Modifié par Le Pingou le 20/02/2014 à 14:14
Bonjour,
La formule qui suit vous calcul le solde si elle trouve un numéro correspondant en feuille 2 sinon retourne la valeur de la feuille 1.
=SI(ESTNA(RECHERCHEV(B10;'Feuille 2'!$B$10:L16;4;FAUX));I10;I10-RECHERCHEV(B10;'Feuille 2'!$B$10:L16;4;FAUX))

note: la formule en feuille 1 cellule [K10] et tirer vers le bas.
Salutations.
Le Pingou
0
yo-72 Messages postés 3 Date d'inscription jeudi 20 février 2014 Statut Membre Dernière intervention 20 février 2014 1
20 févr. 2014 à 15:45
Merci beaucoup !!!! ca marche du tonnerre, j'aurais jamais trouvé tout seul.
Ca va grandement me faire gagner du temps. ; ))))
0