Recherche d'une occurrence à partir d'une liste

[Résolu/Fermé]
Signaler
-
 charlotte -
Bonjour à tous

Voilà : j'ai une trèèèès longue liste d'associations dans un fichier excel, et à coté, une nomenclature que voici : http://www.assobase.org/aide/waldek
Pour chaque association, j'ai dans le fichier soit la catégorie soit la sous catégorie...
Je voudrais avoir une colonne pour chaque catégorie, et que, si une des sous-catégories de la liste figure dans mon fichier d'association, une formule renvoie 1, pour faire le total du nombre d'associations par catégorie. Sans me fader une formule de type =SI(NB.SI($A6;"*Danse*");1;""), vu qu'il y a plus de cent sous-catégories à checker...

J'espère être suffisement claire et vous remercie d'avance

J'espère que vous pourrez m'aider

Charlotte

1 réponse

Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
Bonjour
je en vois pas comment utiliser votre modèle, mais je ne comprend pas bien làourquoi votre formule est si compliquée:
=NB.SI(A1:Z1000;"*danse*") vous renverrait directement le nombre de cellules qui contiennent danse dans le champ A1:Z1000
crdlmnt

Tout à fait, le problème c'est qu'après la danse, il y a encore une centaine de catégories. J'aimerais éviter de faire 100 formules, mais chercher directement à partir de la liste.
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
100 formules?, ce n'est pas un problème.
Si vous avez une liste des codes à chercher (il la faudra bien, celle là)par exemple en Y à partir de Y1, il suffit d'écrire en Z1:

=NB.SI(Champ;"*"&Y1&"*") et à tirer sur la hauteur (3 secondes maxi)

ou d'écrire Y1:Y100 dans la case à gauche de la barre de formule et tpouche ENTER
ensuite d'écrire la formule qui correspond à la ligne 1 dans la barre de formule et d'entrer en maintenant la touche ctrl enfoncée
crdlmnt
Merci, c'est bien ce qu'il me fallait !

Bonne continuation