Formule a multiple conditions [Résolu/Fermé]

Signaler
-
 ikkithousen -
Bonjour,

Est ce que vous pouvez m'aider ? J'essaye de trouver une formule à conditions imbriquées sans résultat.. Je pense qu'il y a trop de conditions justement....
Je voudrais savoir si c'est possible d'avoir une formule qui donne comme résultats :
- si Cellule B contient D13 ou 14 et si Cellule G est entre -2 et 2 alors ne pas archiver
- si Cellule B contient D13 ou 14 et si Cellule G est supérieure à 5 ou inférieure à -5 alors à régulariser
- si Cellule F est égale à 0 alors à vérifier/régulariser
- si Cellule G est entre -2 et 2 alors archiver
- si Cellule G est supérieure à 5 ou inférieure à -5 alors à régulariser

Merci beaucoup pour votre aide :)
Je n'ai réussi qu'une partie de la formule...

3 réponses

Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 738
Bonjour
=SI(F13=0;"à vérifier / régulariser";SI(ET(OU(B13=D13;B13=D14);OU(G2<=2;G2>=-2));"ne pas archiver";SI(ET(OU(B13=D13;B13=D14);OU(G2<=-5;G2>=5));"à régulariser";SI(OU(G2<=2;G2>=-2);"archiver";SI(OU(G2>=5;G2<=-5);"à régulariser";"")))))

1°) employez les bons N° de ligne pour F et B , vous ne les avez pas précisés.
2°) Excel s'arrètant de lire la formule dès qu'une condition est remplie, placez l'item SI(F&"=0;"à vérifier/ régulariser" devant ou derrière les items suivants selon besoins

crdlmnt.


Bonjour Vaucluse,
Tout d'abord merci d'avoir répondu :)
J'ai essayé la formule et ça ne fonctionne pas... J'obtiens # NOM?
La formule doit se faire sur la même ligne.
- si Cellule B2 contient "D13" ou "14" et si Cellule G2 est entre -2 et 2 alors ne pas archiver
- si Cellule F2 est égale à 0 alors à vérifier/régulariser
- si Cellule G2 est entre -2 et 2 alors archiver
- si Cellule G2 est supérieure à 5 ou inférieure à -5 alors à régulariser

J'ai enlevé une condition car elle faisait doublon.

MERCI pour ton aide :)
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 738
RE
c'est normal, je pensais que D13 et 14 était des adresses de cellule,mais si ce sont des textes, il faut les mettre entre guillemets si texte, direct si numérique
donc .......SI(B2="D13";B2=14).......
crdlmnt
Vaucluse

la formule s'applique seulement si F2=0 et tout le reste est à archiver..... et quand j'ajoute & a chaque item j'ai le résultat #NOM?

Merci de ton aide
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 738
Bonjour

pourquoi ajouter des &, il ne s'agit pas de cumuler les résultats?

voyez ici, ça vous aidera peut être à comprendre ou au moins à vous expliquer mieux!

https://www.cjoint.com/?DBqhFaROuPA

Les condition s'y appliquent dans l'ordre o du tableau. Le résultat correspond à la 1° condition trouvée correcte par Excel

à vous lire

crdlmnt
Messages postés
53146
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 janvier 2021
15 132
Bonjour IkkiThousen.

Tes contraintes ne sont pas clairement exposées ! En effet :
- que se passe-t-il si F2=0 et G2=0 ? D'aprés ton instruction 2 il faudrait afficher "vérifier/régulariser" mais d'après ton instruction 3 ce serait "archiver" ! Que choisir ?
- si F2>0 et 2<G2<5, on affiche quoi ?

Dans l'attente ...
Bonjour Raymond,

En fait j'ai déjà trouvé la formule qui est
=SI(L21=0;"A vérifier et/ou à régulariser";SI(M21>5;"A régulariser";SI(M21<-2;"A Regulariser";"A archiver")))

Mais je voulais savoir si c'était possible de lui demander en plus de ne pas archiver si dans la Cellule E21 il y a OPT13 ou OP(lettre quelquonque)14, je vais essayer d'ajouter ceci pour voir
SI(ET(E21="OPT13*";E21="OP*14";"Ne pas archiver"))

Merci
J'ai fini par trouvé la bonne formule!
Merci à vous ;)