Calcul nombre heures entre 2 dates différentes

Résolu/Fermé
Signaler
-
Messages postés
378
Date d'inscription
vendredi 12 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
-
Bonjour.

Je sollicite votre aide pour deux problèmes qui au demeurant pourrait paraitres simples pour des fondus d'Excel, mais prise de tête pour des passionnés mais avec des connaissances basiques, ce qui est mon cas...

J'explique:

1- Je souhaite faire apparaitre dans une cellule le nombre d'heures écoulés entre deux périodes horaires, mais qui sont sur deux jours différents. Ceci étant pour un calcul du nombres d'heures de travails de mes subordonnés. C'est à dire (un exemple concret étant plus explicite...):

Début de poste:
20:35 (cellule D2)

Fin de poste:
04:40 (cellule E2)

Je souhaiterais que ma cellule du total fasse donc apparaître:
08:05 (qui est le temps de travail effectifs, cellule F2)

Hors, j'ai beau fouiller sur le net et sur ce présent forum, je ne trouve point de réponses satisfaisantes.
Je précise que le format affiché et déja de type " hh:mm ".


2- Dans deux cellules à coté de ce total de 08:05, je souhaiterais également faire le distingo entre heures de jour et heures de nuit.

C'est à dire, par exemple dans la cellule G2 (nommée Jour), doit apparaître 00:25, et dans la cellule H2 (nommée nuit), doit apparaître 07:40.
Ce distingo est à faire puisque l'on considère le travail de nuit entre 21h00 et 06h00.

J'espère que vous pourrez m'aider dans ma démarche car j'avoue que cela fait pas mal de jour que je bûche sur ce problème et que je ne trouve pas de solution. Si possible une solution simple...

Merci par avance de votre aide qui, je n'en doute pas, sera précieuse.

Riquette.
A voir également:

3 réponses

Messages postés
378
Date d'inscription
vendredi 12 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
22
Bonsoir:

Essaye cette solution

Début: cellule D2: 20:35
Fin: cellule E2: 04:40

choisir une autre cellule (qu'elle soit par exemple A1)
Saisir dans A1: 12:00 (douze heure pile)

Alors dans F2 saisir la formule : =SI(E2>D2;E2-D2;E2-D2+2*(A1))
1
Messages postés
16546
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 janvier 2022
3 259
Bonjour
=MOD(E2-D2;1)

pour les heures jour nuit

si heure d'arrivée >seuil nuit alors 0 sinon mod(seuil-heure arrivée;1)

m^me punition pour les heures nuit

piège;
heure de sortie > fin nuit
0
Messages postés
26395
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2022
6 182
Bonjour

pour calculer le total des heures à cheval sur deux jours, si bien sur il ne dépasse pas 24:
=MOD(Deb-fin;1)

aziz pour info:
avec 12: en A1 A1+A1 est toujours égal à 1, donc votre formule fonctionne même en l'arrêtant à +2
(mais je pense que MOD est plus simple.

crdlmnt
0
Messages postés
378
Date d'inscription
vendredi 12 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
22
je viens de rectifier (Avant j'ai mis A1+A1 et au lieu de mettre 2*A1 j'ai mis 2*(A1+A1)

Merci pour la remarque
0