Résultat multiple

Résolu/Fermé
pat39400 - 1 févr. 2014 à 15:04
pat39400
Messages postés
1
Date d'inscription
samedi 1 février 2014
Statut
Membre
Dernière intervention
2 février 2014
- 2 févr. 2014 à 13:29
Bonjour,

sous excel, j'ai une liste déroulante A1 avec A, B, C....

B1=A => B2=0 B3=1
C1=B => C2=0 C3=1
D1=C => D2=1 D3=8
....

j'aimerai avoir un double résultat C5 et C6 selon
Si A1="A" (de B1) alors C5=B2 et C6=B3;Si A1="B" alors C5=C2 et C6=C3....

Merci de votre aide

3 réponses

Raymond PENTIER
Messages postés
56107
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 mai 2022
17 210
2 févr. 2014 à 01:36
Pas très clair !
Mais enfin pour répondre sans chercher plus loin, saisir en C5 la formule
=SI(A1="A";B2;SI(A1="B";C2;"")) et la recopier en C6.
Avec 3 possibilités ça donne =SI(A$1="A";B2;SI(A$1="B";C2;SI(A$1="C";D2;"")))
0
Raymond PENTIER
Messages postés
56107
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 mai 2022
17 210
Modifié par Raymond PENTIER le 2/02/2014 à 02:31
Mais si j'ai bien deviné ce que tu veux, il y a une méthode bien plus appropriée :
1) Saisir les données de "A" à "H" dans la plage B1:I1, plage pour laquelle on définit le nom "ref".
2) En A1, insérer une liste déroulante avec "ref" comme source.
3) En B2:B3 saisir les données relatives à "A", en C2:C3 celles relatives à "B" et ainsi de suite jusqu'à IE:I3 pour celles relatives à "H".
4) Sélectionner B1:13 et faire Noms définis/Depuis sélection/Ligne du haut
5) En C5, saisir la formule =INDEX(INDIRECT($A$1);1)
6) En C6, saisir la formule =INDEX(INDIRECT($A$1);2)

Attention
: "C" est un
nom réservé
et ne peut pas désigner une plage nommée (il représente le disque dur). Il faut donc mettre "CC" ou, comme le fait automatiquement Excel dans notre procédure, "C_".

https://www.cjoint.com/?DBcczUUHuhS

Cordialement.
C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
0
pat39400
Messages postés
1
Date d'inscription
samedi 1 février 2014
Statut
Membre
Dernière intervention
2 février 2014

2 févr. 2014 à 13:29
Merci Raymond, les deux solutions me conviennent et fonctionnent, tu as tout à fait compris ma demande, je me la garde dans un coin.
Profites bien de ta retraite, et merci de penser à nous.

Mon problème est résolu, ;>)
0