Prise en compte d'une cellule au format texte pour un résultat

Résolu/Fermé
Signaler
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015
-
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015
-
Bonjour,

Voilà, je souhaite dans un calcul prendre en compte ou ignorer une cellule afin d'obtenir un résultat.

Il s'agit de calculer un taux horaire dont le calcul est : le salaire+la prime d'ancienneté/temps de travail pour les employés et pour les cadres, le salaire (hors primes)/temps de travail.

ma formule pour le taux horaire une simple addition, division: =((salaire : J8+J9) + (prime d'ancienneté : J15)/(temps de travail : J6)). Mais cette formule ne prend pas en considération la condition "cadre" ou "non cadre", en cellule C4, pour la prise en compte ou non de la prime d'ancienneté.

Merci de votre aide

Cordialement

6 réponses

Messages postés
10616
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
28 novembre 2021
1 239
Bonjour,
Et qu'elle est la prime d'ancienneté pour un non cadre et un cadre .... ?
Ou quelque chose de ce genre :
=si(C4=cadre ;((salaire : J8+J9) + (prime d'ancienneté : « Cadre »)/(temps de travail : J6)) ;
=((salaire : J8+J9) + (prime d'ancienneté : « non cadre »)/(temps de travail : J6)))


Salutations.
Le Pingou
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015

Bonjour,

En faite les cadre ne perçoivent pas de prime d'ancienneté alors que les non cadre si.

Donc conditionner le calcul afin qu'il prenne ou non en compte la prime d'ancienneté en fonction de ce qu'indique la cellule C4.

Merci

Cordialement
Messages postés
10616
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
28 novembre 2021
1 239
Bonjour,
Dans ce cas:
Ou quelque chose de ce genre :
=si(C4=cadre ;(salaire : J8+J9) /temps de travail : J6 ;((salaire : J8+J9) + (prime d'ancienneté : J15))/(temps de travail : J6)))

Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015

Bonjour,

Voilà j'ai avec ton aide trouvé la bonne formule
=SI(B4="non cadre";(C9+C10+C16)/C7)&SI(B4="cadre";(C9+C10)/C7)

Mais en fonction de la sélection de la cellule B4 (cadre/non cadre) le résultat que j'obtiens et ainsi FAUX17,3996175908222 pour le statut cadre et ainsi pour le statut non cadre 17,5136150853827FAUX.

Ma question maintenant, comment ne faire apparaitre que le résultat sans FAUX


Merci
Messages postés
10616
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
28 novembre 2021
1 239
Bonjour,
La formule correcte est :
=SI(B4="non cadre";(C9+C10+C16)/C7;(C9+C10)/C7)



Salutations.
Le Pingou
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015

Merci beaucoup du coup de pousse.

C'est appréciable de savoir qu'il y a quelqu'un pour aider lorsque l'on ne sait pas ou que l'on a besoin de précision.

Bonne journée