Désactiver carte graphique ATI Radeon HD 4530/4570/545v [Résolu/Fermé]

Signaler
Messages postés
19
Date d'inscription
lundi 7 février 2011
Statut
Membre
Dernière intervention
27 janvier 2014
-
Messages postés
19
Date d'inscription
lundi 7 février 2011
Statut
Membre
Dernière intervention
27 janvier 2014
-
Bonjour,

J'ai un samsung r540, tournant sous Ubuntu. Mon problème principal est une surchauffe certaine de la machine, un ralentissement paralysant (quelques cas d'extinction), apparemment dus au fait qu'aucun driver propriétaire ne soit fourni après ubuntu 12.04. J'étais sous ubuntu 13, alors je suis retourné sur la version 12.04, en faisant bien attention à installer la dernière version recommandée du pilote, avec la dernière version supportée d'ubuntu. J'ai donc la combinaison suivante : ubuntu 12.04, noyau 3.2.0-58, Xorg 1.11.3, ce qui est sensé respecter les exigences du pilote d'amd, "for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4".

Malgré ces précautions, rien ne semble vraiment changer... puis j'ai appris que mon processeur i3 contenait un chipset graphique intégré. Est-ce qu'il y a moyen de désactiver la carte d'ati, et d'utiliser le chipset intel ? J'espère que ma question n'est pas trop stupide...

4 réponses

Bonjour,
Les cas de surchauffe avec les cartes graphiques ati ne sont pas rares. Ce problème est dû au fait que le driver libre radeon gère mal l'énergie, alors ça chauffe et les batteries se déchargent plus rapidement. Généralement, le problème se règle quand on installe le pilote propriétaire catalyst.

Ce qui compte ce n'est pas tellement la version de xorg, c'est le pilote de la carte graphique (libre ou propriétaire). Par défaut, ubuntu installe le pilote libre radeon. Le gestionnaire de pilotes propriétaires d'ubuntu te propose probablemement plusieurs versions de catalyst.
Sur les versions d'*buntu ultérieures à la 12.04, il ne faut plus utiliser le gestionnaire de pilotes propriétaires pour installer le driver video. Toutes mes tentatives d'installation par ce biais ont échoué (même avec le .run d'amd), par contre un simple
sudo apt-get install fglrx
tapé dans le terminal installera une version du pilote compatible avec ta distribution (y compris pour la 13.10; je l'ai fait il y a peu de temps)
http://doc.ubuntu-fr.org/catalyst
Messages postés
19
Date d'inscription
lundi 7 février 2011
Statut
Membre
Dernière intervention
27 janvier 2014
3
Merci pour ta réponse ! Malheureusement, rechignant à réinstaller Ubuntu quand j'étais avec Ubuntu 13, j'avais à peu près tout essayé, y compris
sudo apt-get install fglrx
... et ça ne marchait pas. C'est pourquoi j'en arrive maintenant à ne plus chercher à faire fonctionner ma carte ati, mais chercher à la désactiver.
Si j'en crois différents articles sur le net, la carte ati mobility radeon 5145 qui équipe ce pc serait en fait une carte radeon HD 4570 renommée. Oui, c'est comme ça qu'AMD sort de nouvelles cartes en modifiant simplement des fréquences...

Tu peux vérifier cette info avec la commande
lspci | grep VGA
.
Si la commande retourne [Mobility Radeon HD 4500 Series], l'info est exacte.

Pour ce qui est de désactiver la carte ati, je ne connais pas cette carte, regarde sur cette page si une des 3 méthodes proposées peut convenir :
http://doc.ubuntu-fr.org/amd-ati?redirect=1#systemes_a_cartes_graphiques_hybrides_intelamd
Messages postés
19
Date d'inscription
lundi 7 février 2011
Statut
Membre
Dernière intervention
27 janvier 2014
3
Merci encore, voilà une piste que je ne connaissais pas ! J'ai essayé avec vga_switcheroo, mais ça n'a rien donné, de même qu'avec la méthode apci... Quand je dis que ça n'a rien donné, je veux dire par là qu'il a fallu moins de 10 minutes pour atteindre 75°C, et finalement pour que mon ordi s'éteigne misérablement, quand je relisais ton lien.
Mais une chose me trotte, ma carte graphique fait partie d'un système de carte switchable ? C'est à dire que je pourrais en théorie passer de la ATI à la Intel et vice versa ? Sur windows il n'y a rien de tout ça, et l'ordinateur semble fonctionner assez normalement...
Chez moi, que ce soit sous enlightment, xfce, ou mate ça fonctionne avec plus ou moins de d'influence sur la température mais je pense que ça vient de la différence de lourdeur des environnements de bureau. En effet si tu utilises unity, l'accélération graphique est requise et cpu et gpu bossent à pleine puissance pour afficher une page alors que sous xfce par exemple pas d'accélération graphique, l'activité cpu et gpu est moindre pour le bureau d'où une plus faible élévation de température.

Je pense que si tu passais à un environnement de bureau plus léger comme xfce, tu gagnerais encore en température (et en performances)
Messages postés
19
Date d'inscription
lundi 7 février 2011
Statut
Membre
Dernière intervention
27 janvier 2014
3
Oui, j'imagine que ces environnements consomment...je ferai un test sous xfce, juste pour savoir. De là à en faire mon environnement par défaut, je ne suis pas pressé, j'apprécie vraiment unity !
Messages postés
19
Date d'inscription
lundi 7 février 2011
Statut
Membre
Dernière intervention
27 janvier 2014
3
J'ai résolu l'histoire de chauffe au retour de l'écran de connexion, il s'agissait d'un processus qui monopolisait l'attention... Bref, j'ai supprimé le programme correspondant (client de connexion de hubiC, qui faisait appel à un processus mono, qui lui, occupait le processeur à 100%...), et la surchauffe n'est plus exagérée lors de la déconnexion/reconnexion.

Tout de même, rester dans les 60-70°C, pour un pc, c'est normal ?
Tout de même, rester dans les 60-70°C, pour un pc, c'est normal ?

Tout dépend de la température critique pour les composants. Soit tu cherches sur le site du fabricant, soit tu as des indications avec la commande
sensors
.
Exemple, chez moi :
~$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +52.0°C (crit = +98.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1: +52.0°C (high = +70.0°C)
(crit = +96.0°C, hyst = +89.0°C)
On voit que la température est considérée comme élevée à partir de 70°C et qu'elle devient critique à partir de 96°C. Là comme je viens de démarrer le pc elle n'est qu'à 52°C, c'est plutôt plus bas qu'avec seven (avec le driver radeon, elle serait probablement supérieure à 65°C)

Un bon indicateur est le bruit du ventilateur : si le ventilateur tourne au ralenti, c'est que la température n'est pas considérée comme élevée. S'il est au maxi, c'est que la température approche la température critique.
Messages postés
19
Date d'inscription
lundi 7 février 2011
Statut
Membre
Dernière intervention
27 janvier 2014
3
L'ordinateur reste aux alentours de 60-70°C. La commande sensors m'indique "high = 80°C" et "crit = 90°C", donc je vais dire que ça va ^^
Merci à tout le monde ! Je passe le sujet en résolu !