Somme avec conditions sous excel

Fermé
michaelt38 Messages postés 1 Date d'inscription samedi 18 janvier 2014 Statut Membre Dernière intervention 18 janvier 2014 - 18 janv. 2014 à 12:11
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 18 janv. 2014 à 12:32
Bonjour je vais essayer de vous décrire mon problème sous excel.

je dois calculer mes heures de trajets quotidienne en enlevant 1/2 heure le matin et pareil le soir.

Je renseigne donc ma feuille de calcul par exemple

en A1 1 heure et en B1 1 heure

seulement certains jour je n'ai rien en A1 ou en B1 je souhaite donc que seul la soustraction du matin se fasse si B1 n'est pas renseigné.et inversement lorsque que A1.

j'espère que vous avez compris ce que je veux dire et pourrez m'aider.

vous remerciant michael

1 réponse

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
18 janv. 2014 à 12:32
Bonjour
voyez pour un champ de A1 à B100

=SOMME(A1:B100)-NB.SI(A1:B100;">0")*0,5/24

qui enlèvera 0:30 mn uniquement lorsque 'il y a un valeur >0 en A ou B

crdlmnt
0