Pas d'aperçu de mon site avec Wordpress ... [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
jeudi 16 janvier 2014
Statut
Membre
Dernière intervention
19 janvier 2014
-
Messages postés
2
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
18 mars 2014
-
Bonjour tout le monde :)

Bon, je vais essayer d'expliquer clairement ce qui m'arrive, je suis novice et le web, c'est un peu du charabia pour moi ...
Voilà, il y a maintenant 6 jours, j'ai acheté un hébergement chez OVH pour créer un site web avec WordPress. J'ai téléchargé FileZilla de façon à pouvoir transférer les données du logiciel Wordpress sur mon serveur FTP, j'ai aussi créé la base de données nécessaire au bon fonctionnement de mon site (avec MySql). Voilà WordPress correctement installé à la racine /www (après plusieurs heures de galère ...), je peux me connecter avec mes identifiants, aucun problème de ce côté là.

Mais voilà, au bout de six jours, je n'ai toujours pas accès à mon site web. Lorsque je tape l'adresse je tombe sur la page "En Construction" du site OVH. J'ai lu sur plusieurs forum (le support d'OVH étant à mon sens beaucoup trop incomplet pour les personnes qui débutent ...) qu'il fallait supprimer le fichier/dossier/lien symbolique index.html qui se colle par défaut sur le serveur FTP. Et là quand je tape l'adresse de mon site, plus de page "En construction" mais simplement une page blanche ...

De plus, lorsque je tente d'avoir un aperçu de ce que je fais sur WordPress, IMPOSSIBLE. Toujours la page blanche.

Je commence à sérieusement perdre patience, le support d'OVH ne me répond pas, et je suis lassée de courir les forums à la recherche de quelqu'un qui aurait eu le même problème que moi ...

Alors oui je sais, je ne suis certainement pas la première à avoir ce souci et à demander de l'aide, et j'espère que ce post ne sera pas fermé parce que je n'ai pas trouvé d'autre post lui correspondant ...

CECI EST UN APPEL A L'AIDE !!! Si quelqu'un de connaisseur et de patient veut bien me donner quelques explications et conseils, je suis preneuse :)

Merci d'avance ...

13 réponses

Messages postés
5840
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
17 mars 2021
1 232
je ne comprends pas tu dis que tu as une page blanche quand tu veux voir ton site et ensuite que tu as une page blanche quand tu essayes d'avoir un aperçu de ton travail sur wordpress donc tu vois bien ton wordpress puisque tu y travailles dessus

ps: un lien vers ton site serait utile
Messages postés
7
Date d'inscription
jeudi 16 janvier 2014
Statut
Membre
Dernière intervention
19 janvier 2014

En fait, j'ai une page blanche alors que j'ai sélectionné un thème prédéfini sur WordPress, donc je devrais voir le thème s'afficher lorsque je tape l'adresse de mon site si tout va bien non ? C'est là que je ne comprends pas pourquoi j'obtiens une page blanche à la place ... J'ai bien sélectionné un thème, mais je ne le vois pas. :/

http://www.crazyvap.com
Messages postés
5840
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
17 mars 2021
1 232
normalement oui

est ce que tu peux prendre une capture d'écran du contenu de www sur ton serveur ftp ou me dire si tu as bien dans le répertoire www le fichier index.php ou un fichier maintenance toujours dans le dossier www
Messages postés
7
Date d'inscription
jeudi 16 janvier 2014
Statut
Membre
Dernière intervention
19 janvier 2014

Euuuuh .. Comment on ajoute une image dans un message sur ce forum ? ^^'

Sinon dans mon répertoire www j'ai bien fait attention d'avoir le fichier index.php qui correspond à la page d'accueil de mon site, mais je ne sais pas ce qu'est un fichier en maintenance ... :/
Messages postés
7
Date d'inscription
jeudi 16 janvier 2014
Statut
Membre
Dernière intervention
19 janvier 2014

Et au même niveau que www j'ai aussi un dossier nommé "net2ftp temp 7ghlh" avec un fichier "htaccess" dedans. Qu'est-ce que c'est ?
Messages postés
7
Date d'inscription
jeudi 16 janvier 2014
Statut
Membre
Dernière intervention
19 janvier 2014

Je viens de m'apercevoir d'un truc : lorsque je suis dans les thèmes qui me sont proposé par défaut dans wordpress (je suis à l'adresse crazyvap.com/wp-admin) et que je clique sur la prévisualisation d'un des thèmes, celui-ci ne s'affiche pas ... De nouveau page blanche :/
Messages postés
5840
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
17 mars 2021
1 232
net2ftp c'est le logiciel de ftp que tu utilises non ? maintenant je sais pas pourquoi il laisse des trucs comme ça

on va faire autrement connecte toi a ton wordpress en tapant tonsite.com/wp-login.php et dans apparence=> thème, mets un des thèmes par défaut de wordpress par exemple twenty eleven et vérifie que la page s'affiche

si ca ne marche encore pas, désactive tous les plugins et vérifie que cela fonctionne, puis remets les plugins un par un jusqu'a que tu trouves le coupable

si ca marche toujours pas, va sur ton ftp et supprime le fichier .htaccess qui est dans www puis connecte toi, va dans réglages=> permaliens et coche une autre case que l'actuelle dans options des permaliens et sauvegarde ( le changement de permaliens va générer un nouveau htaccess) puis revient à l'option précédente en n'oubliant pas de sauvegarder.

si ca ne marche toujours pas, colle le ce code en haut du fichier htaccess
SetEnv PHP_VER 5_4
au cas ou ce serait php la cause

si rien de tout ça fonctionne, tu as le choix entre effacer tout et recommencer manuellement et tout effacer et demander à ovh de l'installer pour toi via les modules
Messages postés
7
Date d'inscription
jeudi 16 janvier 2014
Statut
Membre
Dernière intervention
19 janvier 2014

Bon ... Bin j'ai essayé tout ça, rien n'y fait. Par tout effacer, tu entends réinstaller WordPress ?
Messages postés
5840
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
17 mars 2021
1 232
tu utilises bien net2ftp pour transférer tes fichiers ? si oui essaye de d'effacer ce dossier au cas où ce serait lui le fautif (on ne sait jamais) sinon tu as le choix soit le faire toi même soit demander à ovh de le faire automatiquement pour toi ce qui devrait te garantir que wordpress fonctionne enfin.

attention si tu as des thèmes ou des plugins autres que ceux par défaut (sinon pas la peine, ils seront reinstallés avec le script) dans ton wordpress actuel ils seront tous effacés donc prends soin de les sauvegarder en téléchargeant sur ton ordinateur le répertoire wp-content que tu as sur le ftp avant de tout effacer, si tu as des articles, des pages ou des photos tu dois aussi les sauvegarder ( inutile de les retaper manuellement sur le nouveau puisque wordpress a un outil pour ça) en allant sur wp-admin puis dans le menu outils=>exporter puis vérifie que le bouton tout le contenu est bien coché et clique sur télécharger le fichier d'export

Pour demander à ovh l'installation automatique, il faut d'abord effacer tous les fichiers contenu dans www sur ton site puis te munir des identifiants en particulier le nom de ta base et son mdp d'accès

tu te connectes à ovh.com, tu cliques sur ton nom de domaine dans le menu de gauche puis dans la partie droite sur hébergement=>gestion des modules=>ajouter=>wordpress3

Dans la page qui s'affiche tu va voir une case avec crazyvap.com/WordPress3 qui est le dossier par défaut, supprime WordPress3 pour ne garder que http://www.crazyvap.com pour mettre le blog à la racine .
Clique ensuite sur le mode avancé juste en dessous et choisis installer mon module sur une base deja existante, entre le nom de ta base et le mdp demandé puis valide.

Il ne te reste plus qu'a attendre une quinzaine de minutes puis de regarder tes emails (a l'adresse que tu as indiqué a ovh lors de l'ouverture de ton compte) pour recevoir le mdp qui te permettra de te connecter.

Si tu as fait des sauvegardes
tu te connectes, tu vas dans outils=>importer, tu installes l'importateur wordpress (le lien du bas dans le tableau), tu l'actives et enfin tu charges le fichier de sauvegarde de tes articles puis tu remets les thèmes et les plugins que tu auras sauvegardés en passant par le ftp
Messages postés
7
Date d'inscription
jeudi 16 janvier 2014
Statut
Membre
Dernière intervention
19 janvier 2014

Bonsoir :)

Waou je te remercie de t'impliquer autant c'est très sympa ! Du coup, j'ai pu obtenir l'aide d'une amie à moi qui est webmaster, elle a fouillé un peu partout avec mes identifiants, et en fait le problème venait de mon fichier index.php qui était vide. Je ne sais pas trop ce qu'il fallait mettre dedans, mais apparemment le problème venait de là ! Maintenant j'ai bien mon thème qui s'affiche, tout va bien =)

Merci pour tes conseils, je les garde en tête au cas où un jour il m'arrive d'autres bugs, peut être que ça m'aidera !
Bonne continuation à toi !
Messages postés
5840
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
17 mars 2021
1 232
Comme quoi ce sont souvent les pannes les plus simples qu'on a le plus de mal à trouver
Messages postés
2
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
18 mars 2014

Hello Crazy
j'ai exactement le même soucis que toi, tu as mis quoi finalement dans ton fichier index.php ? ( le mien est vide aussi )
Messages postés
2
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
18 mars 2014

j'ai trouvé le soucis en fait .. c'était bien ce fameux fichier index.php vide que je ne pouvais effacer ... j'avais fais une sauvegarde de mes fichiers, par ftp, j'ai tout effacé, effacer le fichier index mis par défaut par ovh,et tout remis les fichiers wordpress ..
j'espère avoir aidé quelqu'un ..
https://www.youtube.com/watch?v=qwt2yCKJhaw