Mise à jour depuis un fichiers texte

[Résolu/Fermé]
Signaler
-
 kent79 -
Bonjour,
j'ai un tableau excel de ce type:

|N° | Qté |clients | Date |
|----|-------|---------|--------------|
|2 | 712 |client1 |20131230 |
|----|-------|---------|--------------|
|3 | 675 |client3 |20131230 |
|----|-------|---------|--------------|
|4 | 42 |client9 |20131230 |
|----|-------|---------|--------------|
|6 | 25 |client1 |20131230 |
|----|-------|---------|--------------|
|14 | 110 |client1 |20131230 |
--------------------------------------

mon objectif est de mettre à jour "Qté" dans le tableur, grâce à un fichier .txt qui me les récupérer sous le format :

Date; Qté; N°
20140106; 810; 2
20140106; 676; 3
20140106; 130; 4

si quelqu'un peut m'aider car après plusieurs jour d'essaie je bloque. merci d'avance

11 réponses

Messages postés
10486
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
19 octobre 2021
1 215
Bonjour,
Il n'y a pas de référence commune entre les 2 tableaux donc on ne sait pas quelle "Qte" mettre à jour...!
si il y'a le N° (2,4,...)
Messages postés
10486
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
19 octobre 2021
1 215
Bonjour,
Eh oui bien sûr, je suis passé à côté.
Une possibilité... !
Il faut copier le fichier texte sur une feuille (Feuil2) (sous-entendu que le tableau de base est en [Feuil1]) du classeur et le convertir en tableau Excel avec l'outil de données [Convertir] ...suivre les instructions... pour terminer placer la colonne [N°] en première colonne [A :A].
Ensuite dans la colonne [E] (par exemple) de la [Feuil1] vous ajoutez la formule suivante en [E2] :
=SI(NB.SI(Feuil2!$A$2:$A$40;Feuil1!A2)>0;RECHERCHEV(A2;Feuil2!$A$2:$C$40;3;FAUX);Feuil1!B2)
Vous la tirer vers le bas selon le nombre de vos lignes.
Puis en colonne [B] dès [B2] .....
=E2
A tiré vers le bas


Salutations.
Le Pingou
j'ai essayer de reproduire ton aide sur mon cas mais cela ne fonctionne pas.
je détail :

mon fichier .txt est copier en Feuil3 avec B1 "Qté" et C1 "N°". sur x enregistrement.

sur ma Feuil1 : J'ai "N°" à partir de C34 et "Qté" à partir de D34 sur y enregistrement

en O34 j'ai cette ligne : =SI(NB.SI(Feuil3!$C$2:$C$40;Feuil1!B34)>0;RECHERCHEV(B34;Feuil3!$B$2:$C$40;3;FAUX);Feuil1!D34)
et ainsi de suite pour O35, mais quand je D34=O34, la j'ai un problème de référence circulaire.

De plus lors de l'import du fichier tous les N° ne sont pas présent ( exemple en Feuil1 j'ai les N° de 1 à 10, mais dans mon fichier texte j'ai seulement les N° 1,2,3,7,8,9) chaque jour le fichier change et une autre série de N° est importé)
Messages postés
10486
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
19 octobre 2021
1 215
Bonjour,
Et pourtant, j'ai testé et cela fonctionne.
La structure de votre classeur étant différente il faut adapter les formules.
Si vous pouvez mettre votre fichier sur et poster le lien, afin de vous indiquer les bonnes adaptations, cela m'éviterait de reconstruire un classeur selon vos explications !

Messages postés
4
Date d'inscription
mercredi 8 janvier 2014
Statut
Membre
Dernière intervention
9 janvier 2014

je vous est envoyé un MP pour transmettre le fichier excel.
Messages postés
10486
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
19 octobre 2021
1 215
Bonjour,
Désolé pour vous, mon adresse courriel n'est pas disponible

Messages postés
4
Date d'inscription
mercredi 8 janvier 2014
Statut
Membre
Dernière intervention
9 janvier 2014

http://tennisclubantigny.free.fr/ENR-PARC 010 SUIVI DU DERNIER KILOMETRAGE PAR VEHICULE POUR SUIVI VIDANGE.xls

voici un pour obtenir mon fichier excel
Messages postés
10486
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
19 octobre 2021
1 215
Bonjour M. kent79,
Désolé, vous n'avez pas de chance car mon système de protection refuse ce site comme indésirable... donc pas d'accès.
Essayez plutôt avec https://www.cjoint.com/


Salutations.
Le Pingou
Messages postés
4
Date d'inscription
mercredi 8 janvier 2014
Statut
Membre
Dernière intervention
9 janvier 2014

bonjour, voici le lien de mon fichier avec cjoint.com
http://cjoint.com/data3/3Ajia0rHC9l.htm
Cordialement Kent
Messages postés
10486
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
19 octobre 2021
1 215
Bonjour,
Merci pour le fichier.
Petite question, que faites-vous lorsque vous avez un numéro qui se trouve dans la liste (Feuil3) par exemple : 640 et 641 et qu'il ne se trouve pas dans le tableau principal (Feuil1) ?
Merci de votre réponse.

Messages postés
4
Date d'inscription
mercredi 8 janvier 2014
Statut
Membre
Dernière intervention
9 janvier 2014

Les numéro de la Feuil3 qui ne sont pas présent dans la Feuil1, servent pour un autre document qui se base sur le même principe, il est donc normal de ne pas avoir leur référence en Feuil1.
Cordialement
Messages postés
10486
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
19 octobre 2021
1 215
Bonjour,
Au fait, pour votre application, je pense qu'il est préférable de le réaliser avec une petite procédure VBA et dans ce sens pourquoi ne pas intégrer l'autre document de base ...?
La version Excel .....?
Merci de votre renseignement !
Salutations.
Le Pingou
Messages postés
10486
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
19 octobre 2021
1 215
Bonjour,
Merci. Je suis au tennis cette après-midi, une proposition ce soir.

Messages postés
10486
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
19 octobre 2021
1 215
Bonjour,
Ma proposition avec une procédure qui se déclenche lors de l'ouverture du classeur et aussi dès que vous revenez sur la feuille [Base].
Votre fichier : https://www.cjoint.com/?3AjwGc6Ab0n

merci de votre réponse ça fonctionne à merveille.
Bravo, Cordialement bonne continuation