Trop d'arguments pour fonction si

Résolu/Fermé
Rey - 23 déc. 2013 à 13:37
 Mutumbo - 23 déc. 2013 à 14:44
Bonjour,

Je suis entrain de travailler sur un fichier de pointage d'heures.

J'ai trouvé la solution pour les situations mais séparément. Je n'arrive pas à trouver une solution pour les 2 cas.

Voici ce que je veux:

Si le jour J est dimanche, et AX289=0,alors BA289
Sinon Si AV289+AX289>42 et AX289=3,5, alors AS289-35-3,5-8
Sinon si AX289>3,5, alors AS289-35-7

=SI($A289="Dimanche";SI(AX289=0;BA289;SI(AV289+AX289>42;AS289-35-7;AT289-BA289));"")

Ma formule fonction uniquement pour la 2eme condition et si je veux qu'elle marche pour la 1ere, il faut que je mette -11,5 à la place de 7.

J'ai éssayé ce que je savais, mais là j'ai une urgence.

Merci pour votre aide, en espérant que vous m'avez compris.

A bientôt.
Rey


2 réponses

Salut.

=SI(A289="Dimanche";BA289;SI(ET(AV289+AX289>42;AX289=3,5);AS289-35-3,5-8;SI(AX289>3,5;AS289-35-7;)))
0
Salut Mutumbo,

Un grand merci pour la réaction. Ta proposition ne fonctionne pas.

Pas de soucis, j'ai résolu le problème. Encore un grand merci.
A bientôt

Rey
0
Ah ben oui, j'ai zappé le AX289=0 de la première partie.
0
PHILOU10120 Messages postés 6142 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 1 octobre 2022 737
23 déc. 2013 à 13:58
Bonjour

L'énoncé ne correspond pas à votre formule

voici se que j'en ai déduit

=SI(ET($A289="Dimanche";AX289=0);BA289;SI(ET(AV289+AX289>42;AX289=3,5);AS289-35-3,5-8;SI(AX289>3,5;AS289-35-7;"")))
0
Salut Philou,

Ta proposition fonctionne super bien pour mon problème, je n'étais pas loin.

Par contre, elle fonctionne bien que pour les heures supp supérieur à 42ème heure. de 36 à 42 ça fonctionne pas.

Un grand merci pour ta réactivité.

Rey
0
Si les heures sup sont entre 36 et 42 eme alors, BA -AT,
SI AV +AX <42
0