Formule

Fermé
pascauro Messages postés 14 Date d'inscription mercredi 30 octobre 2013 Statut Membre Dernière intervention 19 janvier 2015 - 15 nov. 2013 à 08:24
pijaku Messages postés 12263 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 4 janvier 2024 - 15 nov. 2013 à 09:36
Bonjour,

J'aurai besoin d'aide concernant la formule ci dessous, je n'arrive pas à la faire fonctionner quand j'ajoute d'autres "options

Formule initiale,

=NB.SI(A1:N1;"CP")*7

Je souhaite ajouter par exemple

=NB.SI(A1:N1;"CP" ou "DP" ou "AS" etc etc)*7

Merci à vous

6 réponses

karim.bac2008 Messages postés 6 Date d'inscription dimanche 22 avril 2012 Statut Membre Dernière intervention 15 novembre 2013
15 nov. 2013 à 08:56
bonjour pascauvo,

la formule brut de NB.SI est NB.SI(P;C)
P: plage de votre donnée.
C: critère.
exemple: NB.SI(A1:A22;K6) et K6 contient le condition de (> 10 ou <= 15....etc)

voir le lien ci-dessous peut être
https://www.youtube.com/watch?v=LQQwarCWfqU
0
Zoul67 Messages postés 1959 Date d'inscription lundi 3 mai 2010 Statut Membre Dernière intervention 30 janvier 2023 149
15 nov. 2013 à 08:57
Bonjour

=(NB.SI(A1:N1;"CP") + NB.SI(A1:N1;"DP") + NB.SI(A1:N1;"AS") + etc etc)*7 ?

A+
0
pascauro Messages postés 14 Date d'inscription mercredi 30 octobre 2013 Statut Membre Dernière intervention 19 janvier 2015 1
15 nov. 2013 à 09:01
MERCI
0
Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 525
15 nov. 2013 à 08:58
Bonjour,

=(NB.SI(A1:N1;"CP")+NB.SI(A1:N1;"DP")+NB.SI(A1:N1;"AS"))*7
A+
0
pascauro Messages postés 14 Date d'inscription mercredi 30 octobre 2013 Statut Membre Dernière intervention 19 janvier 2015 1
15 nov. 2013 à 09:01
Bonjour Gyrus et merci

A+
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
michel_m Messages postés 16603 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 16 décembre 2023 3 304
Modifié par michel_m le 15/11/2013 à 09:32
Bonjour

quelque soit les données dans la ligne 1 en décalant une colonne (b1:O1)
https://www.cjoint.com/?3KpjF4pAOgJ

ou sans formule en 3 minutes avec un tableau croisé dynamique (méthode différente suivant version XL <2007 ou >=2007)


Michel
0
pijaku Messages postés 12263 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 4 janvier 2024 2 742
Modifié par pijaku le 15/11/2013 à 09:38
Bonjour,

Le problème est plus mathématiques qu'Excellien.
Ta formule doit :
1- trouver le nombre de cellules entre A1 et N1 qui contiennent "CP"
2- trouver le nombre de cellules entre A1 et N1 qui contiennent "DP"
3- trouver le nombre de cellules entre A1 et N1 qui contiennent "AS"
4- etc
5- Additionner tout ces nombres
6- multiplier le résultat par 7

Soit :
=(NB.SI(A1:N1;"CP")+NB.SI(A1:N1;"DP")+NB.SI(A1:N1;"AS"))*7

Ou, en formule matricielle (à valider par Ctrl+Shift+Entrée) :
=SOMME(SI(A1:N1="CP";1;SI(A1:N1="DP";1;SI(A1:N1="AS";1;0))))*7

Ou encore, en utilisant SOMMEPROD :
=SOMMEPROD((A1:N1="CP")+(A1:N1="DP")+(A1:N1="AS"))*7

EDIT: excusez moi, je n'avais pas rafraichi.........
Bonne journée à tous

Cordialement,
Franck
0