Recherche excel 2 critères ( encore et toujours...)

Résolu/Fermé
Signaler
Messages postés
22
Date d'inscription
jeudi 24 octobre 2013
Statut
Membre
Dernière intervention
28 février 2014
-
Messages postés
22
Date d'inscription
jeudi 24 octobre 2013
Statut
Membre
Dernière intervention
28 février 2014
-
Bonjour à tous,

Je cherche à faire une recherche excel selon 2 critères :
Ayant déja regardé d'autres forum je n'arrive pas à faire focntionner les formules du genre :
=INDEX(C1:C100;EQUIV(A3&B3;A1:A100&B1:B100;0);1)
=SOMMEPROD(A1:A100=D1)*(B1:B100=E1)*(C1:C100)
même en fesant le crtl+ shift+ entré

Ce que je souhaiterai c'est qu'en recherchant 1 code parmis la colonne C et en cherchant le critère "Prix1" parmis l'ensemble de mes colonnes de D à G je retrouve ma valeur.

Je vous inclus mon fichier pour une meilleur compréhension de mes recherches.

je vais inclure mon fichier.

Merci d'avance pour votre aide

5 réponses

Messages postés
22
Date d'inscription
jeudi 24 octobre 2013
Statut
Membre
Dernière intervention
28 février 2014

c
Code Nom produit type Prix1 Prix 2
500001 stylo rouge 10 300
500002 stylo vert 20 400
500003 stylo bleu 30 500
500004 stylo jaune 40 600
Messages postés
22
Date d'inscription
jeudi 24 octobre 2013
Statut
Membre
Dernière intervention
28 février 2014

Je n'arrive pas à joindre mon fichier...
Messages postés
17713
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 décembre 2021
4 862
Bonsoir,

Clic sur ce lien, puis sur Parcourir pour sélectionner ton fichier, puis sur créer le lien
colle dans ta réponse le lien qui sera généré
Messages postés
22
Date d'inscription
jeudi 24 octobre 2013
Statut
Membre
Dernière intervention
28 février 2014

Quel lien ? sérieusement je ne vois rien... lorsque j'écris un message je n'ai pas la possibilité d'ajouter un fichier... mais bref on quand même s'en sortir sans mon fichier je pense.
Merci
Messages postés
17713
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 décembre 2021
4 862
Re,

Ah excuse je l'ai oublié ou il n'a pas été pris en compte.

https://www.cjoint.com/
Messages postés
175
Date d'inscription
jeudi 19 septembre 2013
Statut
Membre
Dernière intervention
26 décembre 2018
63
Bonjour,

Voir exemple en PJ

https://www.cjoint.com/c/CKpjYF6Czuv

Pour retrouver la ville en fonction du nom et du prénom

=INDEX(Villes;EQUIV(1;(Noms=F2)*(Prénoms=G2);0))
Valider avec maj+ctrl+entrée

Jacques Boisgontier
Messages postés
22
Date d'inscription
jeudi 24 octobre 2013
Statut
Membre
Dernière intervention
28 février 2014

En faite je comprend d'ou vien le probleme : mon excel est en anglais. Yes ça marche ! il faut remplacer le EQUIV par match ! merci à tous