Calculer l 'ecart de 2 valeurs changeantes du positif au negatif [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
mardi 20 novembre 2012
Statut
Membre
Dernière intervention
8 novembre 2013
-
Messages postés
4
Date d'inscription
mardi 20 novembre 2012
Statut
Membre
Dernière intervention
8 novembre 2013
-
Bonjour,

En gros j'ai 2 valeurs en B3 et E3.
Tous les jours les valeur changent et peuvent toutes les 2 et indépendamment passer du positif au négatif.
Moi je veux calculer l'écart entre c'est 2 valeurs, et avoir un vide ("") si une des la valeurs E3 n'est pas présente.

Avec la formule SI(E3="";"";SI(B3<0;(B3+E3);SI(E3<0;(B3-E3);(B3-E3)))) marche jusqu'au moment ou les 2 valeurs passent en négatif.
ex B3=-1000 et E3=-800 j'ai un cumul des négatifs est le résultat est -1800.
Alors que je voudrais l'écart entre les valeurs en prenant B3 comment référent, soit avoir le résultat +200.

Je pense qu'il faut une fonction ET quelque part ,mais je gratte et je n'y arrive pas.
J'espère être a peu près claire

Si quelqu un peut m'aider j en serais très reconnaissant.

Merci la Communauté

2 réponses

Messages postés
12777
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
19 octobre 2020
2 043
Bonsoir

Si je comprends bien c'est la valeur absolue de l'écart que tu cherches (sans le signe)

= SI(E3="";"";ABS(B3-E3)) suffit alors

Cdlmnt
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
52462
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 octobre 2020
14 330
Tout-à-fait d'accord !
Messages postés
4
Date d'inscription
mardi 20 novembre 2012
Statut
Membre
Dernière intervention
8 novembre 2013

Oui tout simplement.

Ca marche impeccable.

Merci Bcp