Recherche excel à deux critères [Résolu/Fermé]

Signaler
Messages postés
8
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
29 janvier 2016
-
Messages postés
8
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
29 janvier 2016
-
Bonjour à tous et à toutes,

Je me demandeais si quelqu'un sait une formule de recherche (dans un tableaux donc) à deux critères, du texte, pour trouver le résultat.

Voici un un tableau ci-joint: https://www.cjoint.com/c/CJFp3MLwNB9

Merci beaucoup de votre aide et à très bientôt :)

Cdt
Luca

3 réponses

Messages postés
5527
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
21 novembre 2020
522
Bonjour Luca234

Avec concaténation des colonnes nom et prénom et une recherchev

Votre fichier modifié

https://www.cjoint.com/?3JFquxJgrzy
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 360
Bonjour,

plusieurs possibilité, en voila une

=SOMMEPROD((A2:A8="Lapierre")*(B2:B8="jean")*(D2:D8))

tu peux également mettre les critères dans des cellules exemple le nom en F1, le prénom en F2 la formule devient
=SOMMEPROD((A2:A8=F1)*(B2:B8=F2)*(D2:D8))

tu peux également nommer tes plages ce qui facilite et écourte la formule surtout si tu dois écrire la formule dans une feuille différente, exemple la plage des nom nommée nom, la plage de prénom nommée pren et la plage des sommes nommée som, la formule devient
=SOMMEPROD((nom=F1)*(pren=F2)*(som))

tu peux également créer une colonne dans la quelle tu vas concaténer le nom et le prénom, dans ce cas tu pourras utiliser la bonne vieille fonction RECHERCHEV

une fonction également intéressante, en F1 l'intitulé de ta tête de colonne Nom, en G1 le nom de l'entête de colonne B prénom, l'entête de colonne prix total, en F2 le nom recherché et en G2 le prénom

=BDLIRE($A$1:$E$8;H1;$F$1:$G$2)

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
8
Date d'inscription
lundi 23 septembre 2013
Statut
Membre
Dernière intervention
29 janvier 2016

Bonjour et merci de vos réponses.

Je ne pensais pas que j'aurais la réponse recherchée, et aussi vite.

Les deux manières sont OK pour moi et très simples d'utilisation.

Merci encore de votre soutien et à très bientôt.

Bonne fin de journée.

Luca