Migration d'un site prestashop

Résolu/Fermé
Signaler
-
 rebib770 -
Bonjour,


Voila, je viens de terminer un site ecommerce pour un client, que j'ai réalisé en amont sur MON serveur pro (en attendant que son serveur + nom de domaine soit ouvert), dont voici l'adresse:

=>http://www.unnerfdedesign.fr/prestashop/

Bon il n'est pas totalement fini, mais qu'importe, mon problème est autre. J'ai voulu transférer le site sur le serveur du client, j'ai donc fait les étapes suivantes:

-sauvegarde des fichiers sur mon pc

-exportation de la bdd

------------------------------------------

-transfert des fichiers sur le nouveau serveur

-création d'une nouvelle bdd

-importation de ma bdd

-changement de ces éléments dans le fichiers setting.inc.php:

define('_DB_NAME_', '*********');
define('_DB_USER_', '***********);
define('_DB_PASSWD_', '************');

Le problème rencontré est le suivant: lorsque je me connecte à l'url du site final (www.naiacosmetics.fr), automatiquement, le site est redirigé vers MON url pro sur lequel je bossais le site en amont (http://www.unnerfdedesign.fr/prestashop/).... Comment cela est-il possible??

Merci d'avance pour votre aide!



4 réponses

Messages postés
17998
Date d'inscription
dimanche 29 octobre 2006
Statut
Contributeur
Dernière intervention
7 juin 2020
3 330
Salut,
tu dois modifier dans la base de données (ou dans la config de ce cms) URL du site par défaut qui doit être encore renseigné avec la tienne.


2
Où puis-je renseigner ca?
0
Messages postés
17998
Date d'inscription
dimanche 29 octobre 2006
Statut
Contributeur
Dernière intervention
7 juin 2020
3 330
Soit dans le fichier de configuration regarder si c'est indiquer genre un

config.inc.php ou config.php généralement s'il est présent.

Sinon va dans phpmyadmin, fait une recherche de ton url t une fois trouvé remplaces par la nouvelle.

1
Mystère résolu! Merci à vous!!
1
Messages postés
17998
Date d'inscription
dimanche 29 octobre 2006
Statut
Contributeur
Dernière intervention
7 juin 2020
3 330
De rien il s'agissait bien de ça ? c'était ou?

ça peu toujours servir à quelqu'un d'autre..

;)
0
Pardon oui!

J'ai été tout simplement dans PHPmyAdmin, puis dans ma base de données, dans la table "ps_shop_url" j'ai modifié les urls.

Plus simplement, les modifs peuvent se faire directement dans le panneau d'administration Prestashop ("PREFERENCES-->SEO & URLs")
0
Messages postés
17998
Date d'inscription
dimanche 29 octobre 2006
Statut
Contributeur
Dernière intervention
7 juin 2020
3 330
Merci ;)
0
Bonjour
le meme probleme mais pour les images.
tout se passe bien mais les images du site proviennent d'un autre site ou il était hébergé et sur autre domaine.

le site ne prend pas les images du site en question !!
0