Excel statistique

Résolu/Fermé
Signaler
-
Messages postés
13
Date d'inscription
samedi 19 octobre 2013
Statut
Membre
Dernière intervention
29 octobre 2013
-
Bonjour à tout le monde,

J'ai les données bruts : sexe, âge, catégorie (ouvrier, cadre...), salaire.

Je dois calculer le nombre d'effectifs (par exemple parmi femme, ouvrier) qui ont tel ou tel salaire (ou le salaire compris entre 1300 et 1350). Merci pour vos réponses. Korovenok.P.S. J'ai OpenOffice ou Excel 2003. Merci

2 réponses

Messages postés
13335
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 janvier 2022
2 324
Bonsoir

Pour plus de facilité commence à nommer chaque plage
par exemple si sexe est en colonne A de A2à A100 tu selectionnes la plage A2:A100 et dans la zone Nom tu tapes sexe etc

ensuite avec la fonction magique SOMMEPROD tu trie selon les criteres par ex
=SOMMEPROD((sexe="femme")*(categorie=ouvrier)*(salaire>=1200))

te donneras le nombre de femmes ouvrières avec un salaire de 1200 et plus

=SOMMEPROD((age=30)*(salaire>1500)*(salaire<2000))
le nombre de personnes de 30 ans avec un salaire compris entre 1500 (non compris) et 2000 (non compris)

Etc

Cdlmnt
1
Messages postés
13
Date d'inscription
samedi 19 octobre 2013
Statut
Membre
Dernière intervention
29 octobre 2013

Merci beaucoup pour votre réponse.
Les plages sont déjà nommées... Et juste avec "les noms", cela ne marche pas. J'ai essayé comme :

=SOMMEPROD((B2:B100="F")*(D2:D100="Ouvrier")*(E2:E100<=1300)*(E2:E100>=1350))
la réponse est "0".

Peut-être, non sûrement, j'ai mal compris.
Cordialement, korovenok
0
Messages postés
13335
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 janvier 2022
2 324
C'est normal tu as du inverser les signes < et >
en effet selon ta formule tu recherches les salaires inférieurs ou égal à 1300 et en même temps supérieurs ou égaux à 1350 ! il ne peut y en avoir aucun !

Si tu veux les salaires entre 1300 et 1350 il faut inverser les signes

Cdlmnt
0
Messages postés
13
Date d'inscription
samedi 19 octobre 2013
Statut
Membre
Dernière intervention
29 octobre 2013

Cela ne marche pas. Dans tous les cas merci beaucoup. En essayant, je vais arriver. Cordialement. Korovenok.
0
Messages postés
13
Date d'inscription
samedi 19 octobre 2013
Statut
Membre
Dernière intervention
29 octobre 2013

Cela a marché!!!!!!!!!!!!!!!!!!!!!! Un énorme merci. Korovenok.
0
Messages postés
13
Date d'inscription
samedi 19 octobre 2013
Statut
Membre
Dernière intervention
29 octobre 2013

Je ne sais pas, ce que j'aurais fait sans votre aide!!!!!
0
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 589
Bonjour,

Pour exploiter des données comme tu veux le faire, tu devrais utiliser les tableaux croisés dynamiques qui vont te fournir tout ce que tu souhaites avec un peu de pratique car ils sont faits pour cette fonction.
1
Messages postés
13
Date d'inscription
samedi 19 octobre 2013
Statut
Membre
Dernière intervention
29 octobre 2013

Je vais essayer. Merci pour vos conseils. Korovenok.
0