Formule Excel pour calcul d'heures négatives

[Résolu/Fermé]
Signaler
-
Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
-
Bonjour,

Voici mon problème...

Heures supplémentaires du mois passé: -61:01:00
en G6 (Réf: Septembre -53:28)

Heures supplémentaires du mois actuel -18:12
en G7

Heures supplémentaires à reporter sur le mois suivant: XXXXXXX /#Valeurs?


Comment puis-je calculer correctement les heures négatives ?

J'ai essayé les formules suivantes

=Somme(G6;G7)
AVEC/SANS la personnalisation [hh]:mm ET "-"[hh]:mm


=G6-G7
AVEC/SANS la personnalisation [hh]:mm ET "-"[hh]:mm

Mon collègue m'a suggéré de simplement ajouter manuellement le résultat, mais je souhaite l'avoir fiablement !

Merci x100000 pour vos réponses !


1 réponse

Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 057
Bonjour
si'il s'agit d'afficher le résultat sans valeur numérique:
=SI(G7>=G6;G7-G6;"-"&TEXTE(G6-G7;"[hh]:mm"))

s'il faut garder la valeur numérique
en format de cellule [h]:mm
=SI(G7>=G6;G6-G6;G6-G7)
et une mise en forme conditionnelle sur la cellule résultat, applicable seulement à partir d'excel 2007
la formule de MFC est:
=$G7<$G6
et le format personnalisé
-[h]:mm

mais attention cette valeur reste positive pour des calculs ultèrieurs.
crdlmnt

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 057
Votre problème vient du fait que le fait de formater des cellules en personnalisé avec le signe - ne rend pas sa valeur négative!
et que tous les calculs que vous pouvez faire dessus ne prenne pas le négatif en compte, la cellule reste en valeur absolue.
Je regarde comment on peut traiter le problème autrement, mais il faut remonter assez loin dans votre fichier
et donc il faut un peu de temps
A +
Est-il alors possible de "déformater" depuis la première occurence de formatage en personnalisé ?
Si oui, suffira-t-il ensuite de copier-coller ?!
Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 057
C'est un peu plus compliqué pour établir le cumul continu de l'année, ça risque d'être coton pour comparer le cumul fait et le théorique. En conséquence,je vous fait ici une proposition en rajoutant un tableau de cumul en M4 à M7, qui permet de calculer correctement tous les mois.

Le but de ce petit tableau rajouté est de traiter le cumul en continu, ce qui facilite la pris en compte du > ou< dans les cumuls

Sinon on finit en Décembre avec des formules de 12 mètres!

A noter que le formatage de base des cellules en L7 et M7 est:
personnalisé :[h]:mm
et que ces deux cellules ont reçu une mise en forme conditionnelle pour les valeurs négatives dont le format est:
"-"[h]:mm
ce format ne s'applique (donc le signe moins) que si le résultat est en théorie négatif.On peut aussi sur ce principe affecter une couleur au positif et une au négatif,il suffit de formater la MFC

Mais dans tous les cas, la valeur de la cellule reste absolue et on ne peut pas s'appuyer dessus pour des calculs ultérieurs sans poser des conditions particulières.

Et enfin, les tableaux non remplis des mois à venir donne des valeurs farfelues puisqu'il n'y a pas d'heure effectuées affectées.
Si besoin, on peut éliminer l'affichage, mais est ce bien nécessaire
revenez si besoin de complément

https://www.cjoint.com/?CJklSEsQogH
crdlmnt
Je vous remercie Vaucluse !!!
Je travaille justement pour les heures et l'agenda de 2014 pour mes collègues !
J'y intègre ce que vous m'avez ajouté !
Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 057
Pas de quoi, je passe le fil en résolu
Bonne route